Altiris® IMAGEEXPLORER 6.8 Hilfe

Altiris®
IMAGEEXPLORER 6.8
Hilfe


Anmerkung

ImageExplorer
© 2006 Altiris, Inc. Alle Rechte vorbehalten.
Datum des Dokuments: 19. Juli 2006
Bootworks U.S. Patent Nr. 5,764,593.
RapiDeploy U.S. Patent Nr. 6,144,992.
Recovery Solution, U.S.-Patentnr. 5,778,395, 5,907,672, 4701745, 5016009, 5146221, 5144425, 5463390, 5506580, 5532694, GB 2172127, B 904359, 3606869.
Weitere Patente angemeldet.
Aufgrund der komplexen Struktur von Computersoftware übernimmt Altiris keinerlei Garantien dafür, dass die Altiris-Software fehlerfrei ist, ohne Unterbrechungen arbeitet, mit allen Geräten und Softwarekonfigurationen kompatibel ist oder anderweitig Ihren Anforderungen gerecht wird.
Der Inhalt dieser Dokumentation ist rein informativ und kann jederzeit ohne Benachrichtigung geändert werden. Sie stellt keinerlei Verpflichtung für Altiris dar. Altiris, Inc. übernimmt keine Verantwortung oder Haftung für Fehler oder Ungenauigkeiten in dieser Dokumentation. Die neueste Dokumentation finden Sie auf unserer Webseite unter www.altiris.com.
Altiris, das Altiris-Logo, BootWorks, Eality, ImageBlaster, Inventory Solution, PC Transplant, RapiDeploy, RapidInstall und Vision sind eingetragene Warenzeichen von Altiris, Inc. in den USA. Altiris, das Altiris-Logo und ManageFusion sind eingetragene Warenzeichen von Altiris, Inc. in anderen Ländern.
Altiris Connector, Altiris eXpress, Altiris Protect, Application Management Solution, Application Metering Solution, Asset Control Solution, Asset Management Suite, Carbon Copy, Client Management Suite, Compliance Toolkit, Connector Solution, Contract Management Solution, Deployment Server, Deployment Solution, Energy Saver Toolkit, Education Management Suite, FSLogic, Handheld Management Suite, Helpdesk Solution, Lab Management Suite, ManageFusion, Migration Toolkit, Mobile Client für SMS, Monitor Solution, Network Discovery, Notification Server, Package Importer, Patch Management Solution, Problem Management Suite, Recovery Solution, Security Solution, Server Management Suite, Site Monitor Solution, Software Delivery Solution, SNMP Management, Software Delivery Suite, TCO Management Solution, UNIX Client für SMS, Web Administrator, Web Reports und andere Produktnamen sind Warenzeichen von Altiris, Inc. in den USA und anderen Ländern.
AuditExpress, Scan on Detect und SecurityExpressions sind Warenzeichen von Pedestal Software Inc. in den USA. Audit on Connect und Audit on Detect sind Warenzeichen von Pedestal Software Inc. in den USA und anderen Ländern.
WebLens und Guaranteeing Your Net Works sind eingetragene Warenzeichen von Tonic Software Inc. in den USA.
WebInsight und RUM sind Warenzeichen von Tonic Software Inc. in den USA.
Microsoft, Windows und das Windows-Logo sind Warenzeichen oder eingetragene Warenzeichen der Microsoft Corporation in den Vereinigten Staaten und/oder in anderen Ländern.
HP und Compaq sind eingetragene Warenzeichen der Hewlett-Packard Corporation.
Dell ist eine eingetragene Marke von Dell, Inc.
Macintosh ist ein eingetragenes Warenzeichen der Apple Computer Corporation.
Palm OS ist ein eingetragenes Warenzeichen von Palm Computing, Inc.
BlackBerry ist eine Servicemarke und ein Warenzeichen von Research In Motion Limited Corporation.
RIM ist eine Servicemarke und ein Warenzeichen von Research In Motion (RIM).
Andere Firmennamen, Marken oder Produktnamen sind oder sind evtl. Warenzeichen ihrer jeweiligen Eigentümer.


Altiris ImageExplorer

Der Altiris ImageExplorer bietet Funktionen zur Anzeige und Bearbeitung von Image-Dateien. Image-Dateien werden mithilfe des Dienstprogramms RapiDeploy erstellt. Dieses Tool wird häufig in Deployment Solution zur Erstellung und Verteilung von Datenträger-Image-Dateien (IMG- oder EXE-Dateien mit einem Abbild der Festplatte des Quellcomputers) verwendet.

Mit ImageExplorer können Sie Image-Dateien ändern - Datendateien, Ordner und Anwendungen hinzufügen oder löschen -, bevor ihr Inhalt an einen Clientcomputer verteilt oder dort wiederhergestellt wird. Sie können Eigenschaften anzeigen und Vorgänge ausführen, wie z.B. Dateien extrahieren und auf einem anderen Zieldatenträger speichern oder Dateien von der Wiederherstellung auschließen, wenn die Image-Datei an einen Clientcomputer verteilt wird. Sie können außerdem den Inhalt eines Ordners drucken oder eine Datei mit der zugehörigen Anwendung bearbeiten.

Siehe auch: ImageExplorer verwenden

ImageExplorer-Merkmale
  • Neue Dateien und Ordner hinzufügen
  • Befehlszeilenmodus
  • Images konvertieren
  • Image-Indizes erstellen
  • Dateien und Ordner extrahieren
  • Datenträger, Ordner und Dateien von der Wiederherstellung ausschließen (oder einschließen)
  • Dateien in einem Image suchen
  • Dateien mit dem zugehörigen Programm öffnen und bearbeiten
  • Selbstextrahierende Images erstellen
  • Image-Baumstruktur von Dateien, Ordnern und Datenträgern drucken
  • Dateien ersetzen
  • Zum Inhalt der ursprünglichen Image-Datei zurückkehren
  • Images teilen
  • Image-Beschreibung anzeigen, hinzufügen oder ändern
  • Eigenschaften von Dateien, Ordnern und Datenträgern in einem Image anzeigen
ImageExplorer-Benutzeroberfläche

Klicken Sie auf das ImageExplorer-Symbol auf der Systemleiste oder klicken Sie auf Extras > ImageExplorer. Dadurch wird das Programm ImgExpl.exe geöffnet, das sich in der Deployment-Freigabe befindet.
Sie können Image-Dateien im systemeigenen IMG-Dateityp oder Image-Dateien mit gepackten rdeploy.exe-Laufzeitversionen des EXE-Dateityps öffnen und bearbeiten.

Altiris ImageExplorer stellt die folgenden Funktionen bereit, um die Datenträger-, Ordner- und Dateielemente einer Image-Datei anzuzeigen, zu verwalten und zu ändern.

Funktion
Beschreibung
Schalt-fläche
Zugriff
Datei hinzufügen
Fügt der Image-Datei eine neue Datei hinzu. Siehe Neue Dateien hinzufügen.
Die Funktion Datei hinzufügen ist durch Rechtsklick auf einen Datenträger, Ordner oder eine Datei in der Strukturansicht verfügbar. Wenn Sie mit der rechten Maustaste auf eine Datei klicken und Datei hinzufügen wählen, wird die neue Datei demselben Ordner hinzugefügt.

Option 1: STRG-A
Option 2: Klicken Sie auf Bearbeiten > Datei hinzufügen
Option 3: Klicken Sie mit der rechten Maustaste auf ein Element und wählen Sie Datei hinzufügen
Ordner hinzufügen
Fügt der Image-Datei einen neuen Ordner hinzu. Klicken Sie auf ein beliebiges Element, um dem Containerobjekt einen Ordner hinzuzufügen.
Auf die Funktion Ordner hinzufügen kann durch Rechtsklick auf einen Datenträger, Ordner oder eine Datei in der Strukturansicht zugegriffen werden.

Option 1: STRG-D
Option 2: Klicken Sie auf Bearbeiten > Ordner hinzufügen
Option 3: Klicken Sie mit der rechten Maustaste auf ein Element und wählen Sie Ordner hinzufügen
Image konvertieren
Konvertiert Image-Dateien vom Dateiformat 4 in das zurzeit von RapiDeploy verwendete Format. Siehe Ein Image konvertieren.
Option 1: STRG-T
Option 2: Klicken Sie auf Datei > Image konvertieren
Kopieren
Kopiert eine Datei oder einen Ordner von einem Standort und fügt sie/ihn in eine Ziel-Image-Datei ein.
Hinweis: Das Kopieren großer Datenmengen und einer großen Anzahl Dateien von einer Image-Datei in die andere kann mehrere Minuten in Anspruch nehmen.

Option 1: STRG-C

oder

Option 2: Klicken Sie auf Bearbeiten > Kopieren

oder

Option 3: Klicken Sie mit der rechten Maustaste auf ein Element und wählen Sie Kopieren
Image-Index erstellen
Erstellt einen Image-Index zur Erleichterung der Wiederherstellung von Images. Siehe Einen Image-Index erstellen.
Option 1: STRG-I
Option 2: Klicken Sie auf Datei > Image-Index erstellen
Ausschließen
Markiert Datenträger, Ordner und Dateien, die nicht eingeschlossen werden sollen, wenn die Image-Datei auf Clientcomputern implementiert wird.
Hinweis: Sie können eine Datei auch ausschließen, indem Sie das Kontrollkästchen neben der Datei im Bereich Details markieren. Das Symbol [image] ersetzt das Kontrollkästchen.

Option 1: Entf-Taste

oder

Option 2: Klicken Sie auf Bearbeiten > Ausschließen.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf eine Datei und wählen Sie Datei(en) ausschließen
Extrahieren
Extrahiert einen vollständigen Datenträger, einen Ordner (samt Unterordnern) oder eine Datei aus der Image-Datei. Hier können Sie einen Zieldatenträger oder ein Zielverzeichnis auswählen, wo die Ordner oder Dateien gespeichert werden sollen. Siehe Einen Ordner extrahieren.
Hinweis: Die Extrahierung großer Datenmengen und einer großen Anzahl Dateien kann mehrere Minuten in Anspruch nehmen.

Option 1: STRG-E

oder

Option 2: Klicken Sie auf Bearbeiten > Extrahieren.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf ein Element und wählen Sie Datei(en) extrahieren
Suchen
Innerhalb einer Image-Datei können Sie anhand spezifischer Namen oder Platzhalterzeichen nach Dateien oder Ordnern suchen. Sie können ? als Variable für ein einzelnes Zeichen oder * (Sternchen) für mehrere Zeichen verwenden. Siehe Dateien suchen.

Option 1: STRG-F

oder

Option 2: Klicken Sie auf Bearbeiten > Suchen.

Option 3: Klicken Sie mit der rechten Maustaste auf ein Containerobjekt und wählen Sie Suchen
Einschließen
Ermöglicht das Einschließen von zuvor als Ausgeschlossen markierten Datenträgern, Ordnern und Dateien in der Image-Datei, wenn diese auf einem Clientcomputer implementiert wird.
Hinweis: Sie können eine zuvor ausgeschlossene Datei auch einschließen, indem Sie das [image] neben der Datei im Bereich Details markieren. Ein Kontrollkästchen erscheint.

Option 1: Einfg-Taste

oder

Option 2: Klicken Sie auf Bearbeiten > Einschließen.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf ein ausgeschlossenes Element und wählen Sie Einschließen
Selbstextrahierend machen
Erstellt eine selbstextrahierende Datei aus einer vorhandenen Image-Datei. Siehe Selbstextrahierende Images erstellen.
Option 1: STRG-M
Option 2: Klicken Sie auf Datei > Selbstextrahierend machen
Datei öffnen
(verfügbar für Dateien)
Öffnet eine Datei mit der zugehörigen Anwendung, wenn die Anwendung auf dem Computer, auf dem ImageExplorer ausgeführt wird, vorhanden ist.

Option 1: Doppelklick

oder

Option 2: Klicken Sie auf Bearbeiten > Öffnen.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf die Datei und klicken Sie auf Öffnen.
Datei öffnen mit
Ermöglicht das Öffnen der Datei mit dem ausgewählten Programm. Wenn die Datei bereits einem Programm zugeordnet ist, können Sie sie einfach durch Doppelklick öffnen. Verwenden Sie Datei öffnen mit, um das Programm zu ändern oder die Standardfunktion 'Schnell öffnen' auszuwählen.
Hinweis: Mit IBMaster 4.5 erstellte Image-Dateien werden nicht geöffnet. Sie können jedoch die Funktion Ein Image konvertieren verwenden, um Image-Dateien ins aktuelle RapiDeploy-Dateiformat zu konvertieren.
Option 1: Doppelklicken (falls nicht zugeordnet)

oder

Option 2: Klicken Sie auf Bearbeiten > Öffnen mit.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf die Datei und klicken Sie auf Öffnen mit.
Image-Datei öffnen
Öffnet Image-Dateien, die mit RDeploy.exe oder IBMaster.exe erstellt wurden. Mit IBMaster erstellte Dateien sind schreibgeschützt, können jedoch angezeigt und extrahiert werden. Sie brauchen eine ältere Version von ImageExplorer (Deployment Solution 5.5 oder niedriger, oder RapiDeploy 4.5 oder niedriger), um mit IBMaster.exe erstellte Dateien zu bearbeiten.

Option 1: STRG-O

oder

Option 2: Klicken Sie auf Datei > Öffnen.
Einfügen
Verschiebt eine Datei oder einen Ordner von einem Standort an einen anderen.

Option 1: STRG-V

oder

Option 2: Klicken Sie auf Bearbeiten > Einfügen.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf ein Element und wählen Sie Einfügen
Drucken
Ordner: Druckt die Ordnerstruktur. Schließt Unterordner und Dateien mit ihrem Änderungsdatum, der Änderungszeit und ihrer Größe ein.

Dateien: Druckt die tatsächliche Datei. Das zugeordnete Anwendungsprogramm muss installiert sein, um die Datei drucken zu können (Beispiel: MS Word zum Drucken von DOC-Dateien).
Siehe Ordnerinhalt drucken und Eine Datei drucken.

Option 1: STRG-P

oder

Option 2: Klicken Sie auf Datei > Drucken

oder

Option 3: Klicken Sie mit der rechten Maustaste auf ein Element und wählen Sie Drucken
Eigenschaften
Stellt allgemeine Informationen über den Ordner oder die Datei bereit, wie Größe, Änderungsdaten und Attribute. Eigenschaften werden für Images, Datenträger, Ordner oder Dateien anders angezeigt. Siehe Eigenschaften anzeigen.

Option 1: ALT-Eingabe

oder

Option 2: Klicken Sie auf Datei > Eigenschaften.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf ein Element und wählen Sie Eigenschaften
Dateien ersetzen
(verfügbar für Dateien)
Ermöglicht die Aktualisierung einer Datei im Image mit einer Datei aus einer anderen Quelle. Beide Dateien müssen denselben Namen haben.

Option 1: STRG-L

oder

Option 2: Klicken Sie auf Bearbeiten > Ersetzen.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf eine Datei und wählen Sie Datei(en) ersetzen
Rückgängig machen
(verfügbar für Dateien)
Eine Wiederherstellungsfunktion für die Option Datei ersetzen. Mit dieser Funktion wird eine geänderte Datei wieder in die ursprüngliche Datei verwandelt.

Option 1: STRG-R

oder

Option 2: Klicken Sie auf Bearbeiten > Wiederherstellen.

oder

Option 3: Klicken Sie mit der rechten Maustaste auf ein Element und wählen Sie Datei(en) wiederherstellen
Image teilen
Teilt eine Image-Datei einer Größe, damit ihre Größe dem Segment einer anderen Datei entspricht. Siehe Ein Image konvertieren.
Option 1: STRG-S
Option 2: Klicken Sie auf Datei > Image teilen


ImageExplorer verwenden

Öffnen Sie die anzuzeigende oder zu ändernde Datei, während der ImageExplorer ausgeführt wird, indem Sie Dateien > Öffnen von der Programm-Menüleiste wählen.

Hinweis: Ältere Image-Dateien, die mit IBMaster.exe anstatt der aktuellen RDeploy.exe erstellt wurden, können nicht mit der mit Deployment Solution 5.6 oder höher gelieferten Version von ImageExplorer geändert werden. Image-Dateien, die mit IBMaster erstellt wurden, können jedoch angezeigt werden und Dateien können extrahiert werden. Der ImageExplorer zeigt die mit IBMaster erstellten Dateien als schreibgeschützt an, auch wenn die Dateiattribute Lesen und Schreiben zulassen. Um ältere Image-Dateien zu ändern, müssen Sie die Version des Altiris ImageExplorer verwenden, die mit den früheren Versionen von Deployment Solution geliefert wird.

Siehe auch: Eigenschaften anzeigen, Neue Dateien hinzufügen und Einen Ordner extrahieren.


Eigenschaften anzeigen

Nach dem Öffnen einer Image-Datei mit ImageExplorer können grundlegende Informationen über die Image-Datei und ihre Elemente angezeigt werden, indem Sie einen Datei- oder Datenträger-(Partitions-)Namen auswählen und auf Eigenschaften klicken. Sie können die Eigenschaftsseite für eine Image-Datei, einen Datenträger oder eine Datei öffnen, indem Sie sie/ihn mit der rechten Maustaste anklicken und Eigenschaften wählen und dann auf Datei > Eigenschaften klicken oder ALT-Eingabe drücken. Je nach Typ des Image-Elements wird eine Eigenschaftsseite mit den entsprechenden Registerkarten geöffnet:


Allgemeine Eigenschaften für eine Image-Datei

Diese Seite zeigt Daten für Image-Dateien an. Klicken Sie nach der Auswahl von Eigenschaften für ein ausgewähltes Image auf die Registerkarte Allgemein, um die Image-Elemente und zusätzliche Eigenschaftsdaten wie Größe, Standort und Attribute anzuzeigen.

Die Image-Eigenschaftsseite enthält auch den Namen der Image-Datei und die zugehörigen Image-Daten. Beispiel: Das Feld Größe zeigt an, wie viel Platz das Image auf der Festplatte des Quellcomputers in Anspruch nimmt. Das Feld Größe auf Festplatte zeigt die tatsächliche Größe der komprimierten Image-Datei an, bevor sie implementiert wird.

Sie können das Kennwort der Image-Datei in diesem Dialogfeld ändern.


Allgemeine Eigenschaften für einen Datenträger

Diese Seite zeigt Daten für einen Datenträger an. Klicken Sie nach der Auswahl von Eigenschaften für einen ausgewählten Ordner in einer Image-Datei auf die Registerkarte Allgemein, um seine Eigenschaftsdaten wie Größe, Standort und Attribute anzuzeigen.


Allgemeine Eigenschaften für einen Ordner

Diese Seite zeigt Daten für einen Ordner an. Klicken Sie nach der Auswahl von Eigenschaften für ein ausgewähltes Image auf die Registerkarte Allgemein, um die eingeschlossenen Dateien und Eigenschaftsdaten wie Größe, Standort und Attribute anzuzeigen.


Allgemeine Eigenschaften für Dateien

Diese Seite zeigt Daten für Dateien an. Klicken Sie nach der Auswahl von Eigenschaften für einen ausgewählten Ordner in einer Image-Datei auf die Registerkarte Allgemein, um die eingeschlossenen Dateien und zusätzliche Eigenschaftsdaten wie Größe, Standort und Attribute anzuzeigen.


Beschreibungseigenschaften für ein Image

Diese Seite zeigt die einzelnen Datenträger innerhalb der Image-Datei an. Sie enthält die Anzahl der Datenträger im Image und listet die Namen der einzelnen Datenträger im Bereich Datenträger auf. Wenn Sie Lese-/Schreibrechte für die Image-Datei haben, können Sie die Image-Beschreibung ändern.


Festplattenpartitionseigenschaften

Die Eigenschaftenseite 'Sonstige' enthält eine umfassende Liste von Systemattributen für jeden Datenträger in der Image-Datei. Dazu gehören Datenträgerdaten und Statistik, einschließlich der von der Partitionstabelle importierten Daten.


Eine Datei öffnen

Doppelklicken Sie zum Öffnen einer Datei in einem Image auf die Datei im Bereich Details des ImageExplorer oder klicken Sie sie mit der rechten Maustaste an und wählen Öffnen. Die Datei wird mit dem zugehörigen Programm geöffnet. Wenn kein zuordnetes Programm gefunden wird, erscheint das Dialogfeld Öffnen mit, in dem der Benutzer ein Programm für die Datei auswählen und zuordnen kann.

Hinweis: Sie können eine Datei auch einem Programm zuordnen, indem Sie die Datei mit der rechten Maustaste anklicken und den Befehl Öffnen mit auswählen.

Mit der Funktion Schnell öffnen können Sie ein Standardprogramm zum Öffnen von Dateien auswählen, um Dateien ohne zugeordnetes Programm zu öffnen (Microsoft Notepad ist das Standardprogramm). Sie können das Standardprogramm für die Funktion 'Schnell öffnen' ändern, indem Sie Anzeigen > Einstellungen anklicken und das Feld Öffnen mit Programm bearbeiten.

Siehe auch: Eine Datei drucken und Einstellungen.


Geteilte Image-Dateien öffnen

Wenn ein Image zu groß ist oder wenn Sie sich an Größeneinschränkungen zum Speichern eines Image halten möchten (Beispiel: Teilen von Image-Dateien in 600 MB große Teilstücke, damit sie auf mehrere CDs passen), dann können Sie die Image-Datei mit den Funktionen in RapiDeploy in mehrere Dateien aufteilen. Während der Bearbeitung verfolgt ImageExplorer diese geteilten Image-Dateien und fordert sie dazu auf, zusätzliche verknüpfte Image-Dateien, die nicht im selben Verzeichnis gespeichert sind, zu suchen.


Fehlende geteilte Image-Dateien suchen

Wenn mehrere Dateien eines geteilten Image in verschiedenen Ordnern oder auf separaten CDs aufbewahrt werden, wird dieses Dialogfeld geöffnet, um Ihnen bei der Suche der fehlenden Image-Teildateien zu helfen. Geben Sie einen Pfad ins Feld ein oder suchen Sie mit der Browse-Funktion nach den fehlenden Dateien. ImageExplorer verfolgt alle Dateien in einem geteilten Image und fordert Sie zur Eingabe fehlender Image-Teildateien auf, falls diese sich nicht im selben Ordner befinden.


Neue Dateien hinzufügen

  1. Öffnen Sie Altiris ImageExplorer.
  2. Klicken Sie auf Datei > Öffnen. Wählen Sie eine Image-Datei.
  3. Klicken Sie auf OK.
  4. Klicken Sie mit der rechten Maustaste auf den gewünschten Datenträger oder Ordner im Image und wählen Sie dann Datei hinzufügen. Das Dialogfeld Hinzuzufügende Dateien auswählen wird angezeigt.

Option 1:

    • Suchen Sie eine Datei aus und klicken Sie auf OK. Die neue Datei wird nun im Image angezeigt.

      • Option 2:

    • Ziehen Sie eine Datei vom Windows Explorer in den ausgewählten Ordner oder Datenträger in eine im ImageExplorer angezeigte Image-Datei oder kopieren Sie die Datei und fügen Sie ein. Falls die Option markiert ist (siehe Vorgänge zum Einfügen / Ablegen im Dialogfeld Einstellungen), wird Ihre Entscheidung zum Kopieren einer Datei in die Image-Datei mit einer Meldung bestätigt.

Hinweis: Sie können auf Textdateien zugreifen und sie bearbeiten, indem Sie die Datei im Bereich Details des ImageExplorer-Dialogfelds doppelklicken.


Ein Image konvertieren

Das interne Dateiformat für Images hat sich vom Dateiformat 4 in der Deployment Server-Version 5.5 und niedriger ins Dateiformat 6 in Deployment Server 5.6 oder höher geändert. Das Dateiformat 6 ist seit der Herausgabe gleich geblieben, aber kleine Änderungen wurden vorgenommen, um die insgesamte Formatstruktur zu verbessern.

Mit diesem Merkmal können Sie eine zuvor erstellte Image-Datei auswählen und in das aktuelle Dateiformat konvertieren, das RapiDeploy nun verwendet. Auch wenn das Dateiformat in zukünftigen Versionen von Deployment Server geändert wird, wird die Image-Datei immer in das aktuellste Dateiformat konvertiert.

Achten Sie beim Konvertieren von Image-Dateien auf Folgendes:

  • Wenn ein altes Image eine Image-Indexdatei (.imx) hat, dann wird eine neue Image-Indexdatei erstellt.
  • Wenn einer alten Image-Datei ein selbstextrahierendes Image zugrunde liegt, wird der eingebettete RapiDeploy-Code entfernt, und das Image wird als .img-Datei wiedererstellt. Sie erhalten keine Warnmeldung, dass der eingebettete selbstextrahierende Code entfernt wurde.
  • Wenn ein altes Image ein Kennwort hat, hat die neue erstellte Image-Datei kein Kennwort. Der Benutzer erhält jedoch eine Meldung, die ihn informiert, dass das Kennwort entfernt wurde.
  • Dateikonvertierungen dauern unterschiedlich lang, weil ImageExplorer jedes Segment im Image liest, bevor es in die neue Image-Datei konviertiert wird. Wenn Sie große Dateien mit vielen Segmenten haben, dauert dieser Vorgang länger.
Felddefinitionen

Zu konviertierende Image-Datei: Wählen Sie die Image-Datei aus, die Sie konvertieren möchten.

Aktuelle Segmentgröße: Standardmäßig beträgt die Segmentgröße für RapiDeploy-Images 2 GB.

Aktuelle Segmentzahl: Die Anzahl der Segmente in der Image-Datei.

Neue Ausgabe-Image-Datei: Wählen Sie einen Ordner und Dateinamen für die Image-Datei, die Sie konvertieren möchten, basierend auf der neuen Segmentgröße.

Neue Segmentgröße (MB): Wählen Sie eine Größe für Image-Segmente aus der Dropdown-Liste. Die Liste der Optionen enthält Standardgrößen für CDs, Zip-Laufwerke, usw. Wenn ein Dateisegment diese Grenze erreicht, wird ein neues Segment erstellt, bis das ganze Image konvertiert ist.

Geschätzte Segmentzahl: Die geschätzte Anzahl der Segmente in der Datei, die Sie konvertieren möchten.

So konvertieren Sie eine Image-Datei
  1. Klicken Sie auf Datei und wählen Sie Image-Datei konvertieren.
  2. Klicken Sie auf Durchsuchen, um zu einem Ordner zu navigieren, und wählen Sie eine zu konvertierende Image-Datei.
  3. Klicken Sie auf Durchsuchen, um zu einem Ordner zu navigieren. Geben Sie einen neuen Dateinamen für das konvertierte Image ein.
  4. Klicken Sie auf den Dropdown-Pfeil, und wählen Sie eine Segmentgröße aus der Liste.
  5. Klicken Sie auf OK.


Einen Image-Index erstellen

Mit diesem Merkmal können Sie eine Indexdatei für Image-Dateien erstellen. Diese Indexdatei, gemeinsam mit dem ersten Segment des Image, gibt beim Kopieren von Images auf CDs Dateiinformationen an RapiDeploy weiter, wenn die Image-Datei wiederhergestellt wird.

Beispiel: Wenn Sie ein Image mit mehreren Segmenten haben, z. B. .img, .002, .003 und .004, erstellt ImageExplorer eine Inhaltsangabe am Ende des Segments .004, wodurch die Dateiinformationen für jedes Segment des Image identifiziert werden.

Mit diesem Merkmal wird eine neue Indexdatei mit dem Namen .imx erstellt. Wenn Sie dann die Segmente auf CDs kopieren, können Sie .img und .imx markieren, damit sie auf derselben CD sind. Die anderen Segmente .002, .003 und .004 können nach Bedarf auf zusätzliche CDs kopiert werden. Wenn Sie die CDs zur Wiederherstellung eines Image verwenden, gibt die erste CD mit den .img- und .imx-Dateien RapiDeploy die zur Wiederherstellung des Image notwendigen Informationen. Dies erleichtert die Wiederherstellung von Images, weil es nicht nötig ist, die erste CD, die letzte CD und dann wieder die erste CD einzulegen, nur damit RapiDeploy das Image wiederherstellt.

Sie können Images bei ihrer Erstellung auch in einen Index einfügen, indem Sie die Option Eine Image-Index-(.imx)Datei in RapiDeploy auswählen. Informationen dazu finden Sie im RapiDeploy-Referenzhandbuch.

Felddefinitionen

Zu indizierende Image-Datei: Wählen Sie die Image-Datei aus, die Sie indizieren möchten.

Ausgabeordner für Index (optional): Falls Sie keinen Ordner für die Indexausgabe auswählen, wird die .imx-Datei im selben Ordner erstellt wie das Image, das Sie indizieren möchten.

So erstellen Sie ein Index-Image
  1. Klicken Sie auf Datei und wählen Sie Image-Index erstellen.
  2. Klicken Sie auf Durchsuchen, um zu einem Ordner zu navigieren, und wählen Sie eine Image-Datei.
  3. Klicken Sie auf Durchsuchen, um zu einem Ordner für die Indexdateiausgabe zu navigieren.
  4. Klicken Sie auf OK.


Einen Ordner extrahieren

Verwenden Sie diese Funktion, um einen Ordner oder eine Datei aus einem Image zu nehmen und in einen externen Zielordner zu speichern:

  1. Öffnen Sie Altiris ImageExplorer.
  2. Klicken Sie auf Datei > Öffnen. Wählen Sie eine Image-Datei.
  3. Klicken Sie auf OK.
  4. Wählen Sie einen Ordner im Image, klicken Sie ihn mit der rechten Maustaste an und wählen Sie Ordner extrahieren. Das Dialogfeld 'Durchsuchen' erscheint.
  5. Wählen Sie einen Ordner auf Ihrer lokalen Festplatte oder im Netzwerk aus, in den Sie den extrahierten Ordner platzieren möchten.
  6. Klicken Sie auf OK.

Hinweis: Die Extrahierung großer Datenmengen und einer großen Anzahl Dateien kann mehrere Minuten in Anspruch nehmen.


Dateien suchen

Um Dateien oder Ordner in einer Image-Datei zu suchen, geben Sie eine Zeichenkette oder Zeichen (Buchstaben oder Zahlen) im Feld Suchen nach ein. Sie können das ? (Fragezeichen) als Variable für ein einzelnes Zeichen verwenden, oder das * (Sternchen) für mehrere Zeichen.

Um nach einer Datei zu suchen, wählen Sie eine Image-Datei, einen Datenträgernamen oder einen Ordnernamen aus der Strukturansicht aus, um eine Suchdomäne einzurichten. Sie können die Suchdomäne ändern, bevor Sie auf Suchen klicken.

Felddefinitionen

Ordner einschließen: Wählen Sie diese Option aus, um übereinstimmende Ordner in den Suchresultaten einzuschließen.

Dateien einschließen: Wählen Sie diese Option aus, um übereinstimmende Dateien in den Suchresultaten einzubeziehen.

Dateien und Ordner, die bestimmten Kriterien entsprechen, sind im Ergebnisfeld aufgelistet und werden nach Dateiname und Standort geordnet.


Filterergebnisse

Klicken Sie auf Filter im Dialogfeld Dateien suchen, um eine erweiterte Suche nach Dateien zu öffnen, basierend auf zugeordneten Systemattributen (Schreibgeschützt, Ausgeblendet, System) und ImageExplorer-Attributen (Hinzugefügt, Ausgeschlossen, Ersetzt).

Felddefinitionen

Was suchen: Geben Sie die Zeichenkette oder die Zeichen ein, um eine Datei nach Systemattributen oder ImageExplorer-Attributen der Datei oder des Ordners zu suchen. Klicken Sie auf Übereinstimmende Dateien einschließen, um Dateien auszuwählen. Klicken Sie auf Übereinstimmende Ordner einschließen, um Ordner einzuschließen.

Hinweis: Um in einem bestimmten Verzeichnis zu suchen, wählen Sie das Verzeichnis aus der Strukturansicht und öffnen Sie das Dialogfeld 'Suchen'.

Die folgenden Attribute verwenden Dreiwege-Kontrollkästchen mit den folgenden Merkmalen:

  • Ein voll sichtbares Häkchen bedeutet, dass das Element das Attribut enthalten muss.
  • Ein leeres Kontrollkästchen bedeutet, dass das Element das Attribut nicht enthalten muss.
  • Ein graues Häkchen bedeutet, dass der Wert NULL ist und das Element den Wert haben kann oder nicht.

Attribute: Dies sind die Systemattribute der Dateien, die vom Betriebssystem bei der Erstellung des Image zugewiesen wurden.

Kennzeichen: Dies sind die vom ImageExplorer zugeordneten Attribute.


Selbstextrahierende Images erstellen

Mit dieser Option können Sie eine selbstextrahierende Datei aus einer vorhandene Image-Datei erstellen, damit Sie die ausführbare Datei auf einem Clientcomputer ausführen können. Dies ist nützlich, wenn Sie ein Image auf einem Computer wiederherstellen möchten, der keinen Zugriff auf den Deployment Server und RapiDeploy hat, um Images über das Netzwerk herzustellen.

Sie können Image-Dateien auswählen, die mit RapiDeploy erstellt wurden. Dieses Programm wird seit Deployment Server 5.6 zur Erstellung von Images verwendet wird. Wenn Sie Images haben, die mit Altiris IBMaster 4.5 oder niedriger erstellt wurden, können Sie dieses Merkmal nicht verwenden. Wenn Sie jedoch zu einem Ordner navigieren, um ein Image auszuwählen, werden alle .img-Dateien angezeigt. Sie können das Merkmal Ein Image konvertierenzur Konvertierung des Image in das neueste RapiDeploy-Dateiformat verwenden.

Die selbstextrahierende Datei besteht aus einer gültigen Image-Datei und RapiDeploy, das in der ausführbaren Datei eingebettet ist. Sie können die selbstextrahierende Datei in einen Ordner oder auf einen mobilen Datenträger kopieren und auf einem beliebigen Computer ausführen, oder Sie können eine Implementierungsaufgabe auf dem Deployment Server erstellen und die selbstextrahierende Datei an mehrere Computer verteilen.

Wenn neue Versionen von RapiDeploy durch Upgrades von Deployment Server verfügbar sind, können Sie alle selbstextrahierenden Dateien neu erstellen, indem Sie die Funktion 'Selbstextrahierend machen' erneut ausführen. Der eingebettete RapiDeploy-Code der Image-Datei wird durch die neueste Version von RapiDeploy ersetzt.

Dieser Vorgang kann unterschiedlich lang dauern, weil ImageExplorer nur das .img-Segment ausliest. Ist Ihre Datei 2 GB groß, nimmt die Datei mehr Zeit in Anspruch als bei einem 700 MB großen .img-Segment.

RapiDeploy und ausschließlich das erste Segment der Image-Datei (.img) werden kombiniert, um die ausführbare Datei zu erstellen, die Images wiederherstellt. Alle anderen Segmente, aus denen das ganze Image besteht, einschließlich des Index (.imx), sind erforderlich, wenn ein Image wiederhergestellt wird.

Siehe auch:Siehe Einen Image-Index erstellen.

Felddefinitionen

Aktueller Selbstextrahierungstyp: Die ausgewählte Image-Datei gehört zu diesem Betriebssystemtyp.

Ursprüngliche Image-Datei behalten: Markieren Sie dieses Kontrollkästchen, damit ImageExplorer eine selbstextrahierende Image-Datei erstellt, ohne dass die ursprüngliche Image-Datei davon betroffen wird.

Hinweis: Wenn Sie die Markierung dieses Kontrollkästchens aufheben und der Vorgang Selbstextrahierend machen fehlschlägt, dann wird die ursprüngliche Image-Datei u. U. beschädigt, und Sie können die ursprüngliche Image-Datei nicht mehr zur Erstellung einer selbstextrahierenden Datei verwenden.

Größe der Image-Datei: Die Größe des zurzeit ausgewählten Image.

Vorhandenen Self-Extractor entfernen: Verwenden Sie diese Option zum Entfernen des .exe-Code aus einem selbstextrahierenden Image. Die Image-Datei kehrt mit der Erweiterung .img zu ihrem ursprünglichen Zustand zurück. Diese Option ist nur dann verfügbar, wenn die Image-Datei einen selbstextrahierenden Code hat, andernfalls ist diese Option nicht möglich.

DOS: Dieser Modus verwendet die grafische Benutzeroberfläche von RapiDeploy, um den Fortschritt der Image-Datei während der Ausführung anzuzeigen.

DOS-Textmodus: Dies ist eine Benutzeroberfläche in Textversion. Sie können die Statusleiste unten in der Anzeige des Clientcomputers anzeigen, während die Image-Datei ausgeführt wird.

So erstellen Sie eine selbstextrahierende Image-Datei
  1. Klicken Sie auf Datei und wählen Sie Selbstextrahierend machen.
  2. Klicken Sie auf Durchsuchen, um zum Standort der Image-Datei zu navigieren.
  3. Heben Sie die Markierung von Ursprüngliche Image-Datei behalten auf, wenn Sie die ursprüngliche Image-Datei in eine selbstextrahierende Datei umwandeln möchten.
  4. Wählen Sie Selbstextrahierungstyp ändern. Siehe Felddefinitionen.
  5. Klicken Sie auf OK. Die selbstextrahierende Datei wird im selben Verzeichnis wie die ursprüngliche Image-Datei erstellt. Wenn das Dialogfeld Nicht genügend freier Speicherplatz erscheint, lesen Sie die Informationen unter Nicht genügend freier Speicherplatz.


Nicht genügend freier Speicherplatz

Die Image-Datei, die Sie zu einer selbstextrahierenden Datei machen möchten, kann nicht erstellt werden, weil es nicht genügend freien Speicherplatz gibt. Im Dialogfeld Ungenügend freier Speicher können Sie einen anderen Standort für die Erstellung der selbstextrahierenden Datei auswählen. Geben Sie einen Verzeichnispfad ein, oder klicken Sie auf die Schaltfläche Durchsuchen, um zu einem Standort mit mehr Speicherplatz zu navigieren. Klicken Sie auf OK.


Ordnerinhalt drucken

Sie können eine Liste der Dateien und Unterordner in einer Image-Datei, einem Datenträger (Partition) oder einem Ordner drucken. Je nach den ausgewählten Optionen können Sie einen Bericht drucken, der die Dateien und Unterordner enthält und die Felder mit dem geänderten Datum, der geänderten Zeit, Größe und anderen Attributen für jede Datei einschließt.

Wenn Sie den Inhalt einer Image-Datei, eines Datenträgers oder Ordners drucken, klicken Sie auf OK, um eine Druckvorschauder Berichtdatei anzuzeigen.

Felddefinitionen

Bezeichnung: Geben Sie einen Titel für die Berichtseite ein.

Was gedruckt werden soll

Nur dieser Ordner: Nur die Dateien im ausgewählten Image, Datenträger oder Ordner drucken. Unterordner werden dabei nicht gedruckt.

Dieser Ordner und untergeordnete Struktur: Die Dateien im Image, Datenträger oder Ordner und alle Unterordner und Dateien drucken.

Ausgeschlossene Elemente drucken: Dateien drucken, die zuvor als Ausgeschlossen markiert waren.

Einträge < . > drucken: Einen Eintrag in jedem als < identifizierten Ordner drucken. > (eine punktierte Schreibweise). Attribute und Datums-/Zeiteigenschaften werden für diesen ausgeblendeten Ordner in der Image-Datei gespeichert.

Zu druckende Felder

Änderungsdatum und -zeit einschließen: Datum und Zeit drucken, an dem bzw. zu der die Datei oder der Ordner geändert wurde.

Größe einschließen: Größe der Datei drucken.

Attribute einschließen: Druckt die Systemattribute Schreibgeschützt, Archiv, Ausgeblendet, System oder Komprimiert (Schreibgeschützt, System, Ausgeblendet) und die ImageExplorer-Attribute (Hinzugefügt, Ausgeschlossen, Ersetzt).

Dateinummer einschließen: Die jeder Datei zugeordnete Dateinummer drucken.

Siehe auch: Eine Datei drucken.


Druckvorschau

Zeigt eine Online-Anzeige des Druckberichts für Image-Dateien, Datenträger oder Ordner an. Der Name des Berichts erscheint oben auf der Seite mit Details in einer Tabelle, die im Dialogfeld Ordnerinhalt drucken ausgewählt wurden.

Felddefinitionen

Speichern: Anklicken, um den Bericht in einer Textdatei zu speichern.

Zeilen: Die Anzahl Zeilen im Bericht anzeigen.

Drucken: Zum Drucken des Berichts anklicken.


Eine Datei drucken

Vom ImageExplorer-Dialogfeld aus können Sie eine tatsächliche Datei auswählen und mithilfe des zugeordneten Programms drucken. Wenn Ihrer Datei kein Programm zugeordnet ist, können Sie eines zuordnen, indem Sie es aus der bereitgestellten Liste der auf dem Computer installierten Programme auswählen. Sie können auch einen Schnelldruck versuchen, um die Datei mit einem Standardprogramm wie NotePad zu öffnen.

Felddefinitionen

Schnelldruck: Diese Schaltfläche anklicken, um ein Standardprogramm zum Öffnen und Drucken der ausgewählten Datei auszuführen. Das Standardprogramm ist Microsoft Notepad. Sie können das Standardprogramm zum Drucken von Dateien ändern, indem Sie ein anderes Programm unter Drucken mit Programm im Dialogfeld Einstellungen auswählen.

Siehe auch: Ordnerinhalt drucken und Eine Datei öffnen.


Kennwort für eine Image-Datei festlegen

Klicken Sie mit der rechten Maustaste auf eine Image-Datei und wählen Sie Eigenschaften. Wählen Sie Kennwort im Abschnitt Attribute. Das Dialogfeld Kennwort einstellen / ändern erscheint.

Felddefinitionen

Aktuelles Kennwort: Aktuelles Kennwort eingeben.

Neues Kennwort: Neues Kennwort eingeben.

Kennwort bestätigen: Geben Sie das Kennwort erneut ein, um zu bestätigen, dass es richtig eingegeben wurde.


Einstellungen

Sie können die Einstellungen für Altiris ImageExplorer festlegen, indem Sie auf Anzeige > Einstellungen klicken. Das Einstellungsfeld wird geöffnet, und Sie können Optionen festlegen, um bestimmte Vorgänge mithilfe von Meldungen in der Benutzeroberfläche zu bestätigen, um Optionen zur Anzeige von Elementen oder zum Ausschließen von Elementen einzustellen oder um Standardprogramme für die Optionen Schnelldruck (siehe Eine Datei drucken) oder Schnell öffnen (siehe Eine Datei öffnen) auszuwählen.

Bestätigungen

Schreibgeschützte Dateiöffnungen: Zeigt dem Benutzer eine Bestätigungsmeldung an, wenn eine schreibgeschützte Kopie einer Datei geöffnet wird; Änderungen können in dieser Datei nicht gespeichert werden. Beispiel: Wird eine Image-Datei in RapiDeploy 4.5 oder niedriger geöffnet, ist sie schreibgeschützt, und Änderungen können nicht gespeichert werden. Wird diese Datei geöffnet, erscheint daher eine Bestätigungsmeldung, die den Benutzer daran erinnert, dass die Datei nicht gespeichert werden kann.

Dateiüberschreibungen: Zeigt dem Benutzer eine Bestätigungsmeldung an, wenn eine Datei aus einer Image-Datei extrahiert und eine vorhandene Datei auf einem Ziellaufwerk überschrieben wird.

Dateirücksetzungen: Zeit eine Bestätigungsmeldung an, wenn eine Rücksetzung ausgeführt wird, der die Image-Datei nach dem Ersetzen von Dateien zur ursprünglichen Dateistruktur und zum ursprünglichen Inhalt zurückführt.

Einfügen und Ablegen: Zeigt eine Bestätigungsmeldung an, wenn eine Datei in einen neuen Ordner innerhalb einer Image-Datei gezogen wird, wenn Dateien mit dem Vorgang 'Kopieren und Einfügen' in einen anderen Ordner verschoben werden, oder wenn der Befehl Neue Dateien hinzufügen verwendet wird.

Ausschlüsse: Zeigt eine Bestätigungsmeldung an, wenn die Ausschlussoption einer Datei zugeordnet wird (damit die ausgewählte Datei nicht als Teil des Image verteilt wird). Diese Meldung erscheint, wenn Sie das Kontrollkästchen der Datei oder des Ordners anklicken oder den Ausschluss auswählen.

Ordnerüberschreibungen: Sendet dem Benutzer eine Bestätigungsmeldung, wenn eine Datei aus einer Image-Datei extrahiert und ein vorhandener Ordner auf einem Ziellaufwerk überschrieben wird.

Anzeigeeinstellungen

Hilfe immer im Vordergrund: Wählen Sie dies, um eine offene Hilfedatei immer im Vordergrund der ImageExplorer-Benutzeroberfläche zu halten. Mit dieser Funktion können Sie die Hilfe neben dem Programm anzeigen, anstatt es hinter der ImageExplorer-Benutzeroberfläche verschwinden zu lassen.

Dateinummern anzeigen: Die zugeordneten Dateinummern im Image anzeigen. In NTFS werden die Dateien automatisch nummeriert. In FAT, EXT2, EXT3 und anderen Dateisystemen werden die Dateien von RapiDeploy nummeriert, wenn die Image-Datei erstellt wird.

Ausgeschlossene Elemente anzeigen: Die als 'Ausgeschlossen' markierten Dateien im Image anzeigen. Dateien werden nach der Aktualisierung des Bildschirms angezeigt.

Ausgeschlossene Elemente extrahieren: Die Extrahierung der ausgeschlossenen Dateien und Ordner aus der Image-Datei in einen Zielordner zulassen. Mit dieser Einstellung können Sie alle zuvor als 'Ausgeschlossen' markierten Dateien einschließen, um sie in einem externen Zielordner zu speichern, wenn Sie den Befehl 'Extrahieren' ausführen.

Hinzugefügte Elemente markieren: Wählen Sie diese Option, um Dateien/Ordner, die dem Image hinzugefügt wurden, mit blauer Schrift zu markieren. Siehe Datei hinzufügen und Ordner hinzufügen.

Ersetzte Elemente markieren: Wählen Sie diese Option, um Dateien/Ordner, die im Image ersetzt wurden, mit blauer Schrift zu markieren. Siehe Dateien ersetzen (verfügbar für Dateien).

Ausgeschlossene Elemente markieren: Wählen Sie diese Option, um Dateien und Ordner, die dem Image hinzugefügt wurden, mit roter Schrift zu markieren. Siehe Ausschließen.

Standardprogramme zum Öffnen und Drucken von Dateien

Diese Einstellungen entsprechen den Standardeinstellungen für die Optionen 'Schnell öffnen' und 'Schnelldruck', die mit den Funktionen Öffnen mit und Öffnen erscheinen. Verwenden Sie diese Funktion, um Dateien einem gemeinsamen Programm zuzuordnen, wie z.B. Microsoft Notepad.

Mit Programm öffnen: Stellen Sie das Standardprogramm ein, mit dem die ausgewählte Datei ausgeführt werden soll. Das Standardprogramm ist Microsoft Notepad. Siehe Eine Datei öffnen.

Mit Programm drucken: Stellen Sie das Standardprogramm ein, mit dem die ausgewählte Datei gedruckt werden soll. Das Standardprogramm ist Microsoft Notepad. Siehe Dateien suchen.


Image teilen

Mit dieser Funktion können Sie eine Image-Datei auswählen, die je nach ausgewählter Segmentgröße in eine neue Image-Datei aufgeteilt (neu geschrieben) wird. Während Ein Image konvertieren das Dateiformat eines Image in das zurzeit von RapiDeploy verwendete Format ändert, wird bei der Image-Teilung das Format des ursprünglichen Image beibehalten, aber die Größe seiner Segmente wird geändert.

Beispiel: Wenn Sie eine 2 GB große Image-Datei haben und Sie das Image so aufteilen möchten, dass es auf CDs passt, dann könnten Sie 650 MB oder 700 MB als neue Segmentgröße auswählen und hätten dann eine Image-Datei mit mehreren Segmenten. Die Segmente können Sie dann auf CDs kopieren und zur Wiederherstellung der Image-Datei auf Clientcomputern verwenden.

Achten Sie beim Teilen von Image-Dateien auf Folgendes:

  • Wenn das alte Image in einem alten Format (IBMaster 4.5 oder früher) vorliegt, kann das Image nicht geteilt werden und wird stattdessen konvertiert. Falls dies auftritt, wird eine Meldung angezeigt, in der Sie Ihre Absicht bestätigen können. Wenn Sie fortfahren, gelten alle Prinzipien von Konvertieren und Image herstellen.
  • Wenn ein altes Image eine Image-Indexdatei (.imx) hat, wird eine neue Image-Indexdatei erstellt.
  • Falls eine alte Image-Datei ein selbstextrahierendes Image ist, bleibt der eingebettete RapiDeploy-Code erhalten, und das neue Image enthält dieselbe Version von RapiDeploy wie bei seiner Erstellung. Handelt es sich jedoch um ein Image alten Formats (IBMaster 4.5 oder früher), kann das Image nicht geteilt werden und wird stattdessen konvertiert. Wenn Sie fortfahren, wird der selbstextrahierende Code entfernt.
  • Wenn ein altes Image ein Kennwort hat, bekommt die neue Image-Datei dasselbe Kennwort. Handelt es sich jedoch um ein Image alten Formats (IBMaster 4.5 oder früher), kann das Image nicht geteilt werden und wird stattdessen konvertiert. Wenn Sie fortfahren, wird das Kennwort entfernt.
Felddefinitionen

Aufzuteilende Image-Datei: Wählen Sie die Image-Datei aus, die Sie teilen möchten.

Aktuelle Segmentgröße: Standardmäßig beträgt die Segmentgröße für RapiDeploy-Images 2 GB.

Aktuelle Segmentzahl: Die Anzahl der Segmente in der Image-Datei.

Neue Ausgabe-Image-Datei: Wählen Sie einen Ordner und einen Dateinamen für die Image-Datei, die Sie teilen möchten.

Neue Segmentgröße (MB): Wählen Sie eine Größe für Image-Segmente aus der Dropdown-Liste. Die Liste der Optionen enthält Standardgrößen für CDs, Zip-Laufwerke, usw. Wenn ein Dateisegment diese Grenze erreicht, wird ein neues Segment erstellt, bis das ganze Image geteilt ist.

Geschätzte Segmentzahl: Die geschätzte Anzahl Segmente in der zur Teilung gewählten Datei, basierend auf der neuen Segmentgröße.

So teilen Sie eine Image-Datei
  1. Klicken Sie auf Datei und wählen Sie Image-Datei teilen.
  2. Klicken Sie auf Durchsuchen, um zu einem Ordner zu navigieren, und wählen Sie eine zu teilende Image-Datei.
  3. Klicken Sie auf Durchsuchen, um zu einem Ordner zu navigieren, und geben Sie einen neuen Dateinamen für das Image ein.
  4. Klicken Sie auf den Dropdown-Pfeil, und wählen Sie eine Segmentgröße aus der Liste.
  5. Klicken Sie auf OK.


Befehlszeilenparameter

Mit diesem Merkmal können Sie Deployment Server-Ausführungsskripts oder Batch-Jobs erstellen, um Images von der Befehlszeile aus zu verwalten. Am Ende einiger Parameter werden bestimmte Optionen aufgelistet, die angeben, dass die zusätzlichen Befehle zugelassen sind.

So greifen Sie auf die Online-Befehlszeilenoptionen zu
  1. Klicken Sie von Windows auf Start > Ausführen.
  2. Geben Sie den Befehl CMD im Feld Öffnen ein.
  3. Geben Sie C:\Program Files\Altiris\eXpress\Deployment Server\ (Standardinstallationspfad) ein.
  4. Geben Sie imgexpl /? ein, um die Seite der Befehlszeilenparameter anzuzeigen.
    Befehlszeile
    Beschreibung
    Parameter
    Zu öffnende oder zu bedienende Image-Dateien (kann wiederholt werden, wie z.B. w2k.img, xp.img).
    Parameter
    -register: Dateitypen in der Windows-Registrierung registrieren.
    -unregister: Registrierung von Dateitypen in der Windows-Registrierung aufheben.
    -add <src> <dst>: Datei, Ordner oder Datenträger einem Image hinzufügen. Akzeptiert die Option
    <-overwrite>. Sie können Platzhalterzeichen verwenden, wenn Sie die Quelle (src) angeben.
    -extract <scr> <dst>: Eine Datei, einen Ordner oder Datenträger aus einem Image extrahieren. Akzeptiert die Optionen <-overwrite> und <-size>.
    -convert <dst>: Konvertiert ein Image im alten Format ins aktuelle Image-Format, das von RapiDeploy verwendet wird. Akzeptiert die Optionen <-overwrite> und <-size>.
    -split <dst>: Teilt ein Image in Dateisegmente der neuen Größe. Akzeptiert die Optionen <-overwrite> und <-size>.
    Optionen
    -lang <lang code>: *geben Sie den Sprachcode für die Benutzeroberfläche an.
    -silent: *Bestätigungen oder Fehler nicht anzeigen.
    -password <pwd>: *Kennwörter für Image-Dateien, die geöffnet werden.
    -overwrite: im automatischen Modus werden Aktionen nicht bestätigt.
    -size <Größe in MB>: Größe des neuen Image-Segments in MB.
    * Gibt die Optionen an, die mit jedem Befehl verwendet werden können.
    Prozess-Exit-Codes
    0 Erfolg.
    2 Befehlszeilensyntaxfehler.
    4 Fehler bei Registrierung oder Aufheben der Registrierung von Dateitypen.
    6 Vorgang vom Benutzer abgebrochen.
    8 Es wurde versucht, in ein schreibgeschütztes Image zu schreiben.
    10 Ungültiges Kennwort.
    12 Fehler beim Ausführen eines Vorgangs.
    14 Die Image-Datei wurde nicht gefunden oder beim Öffnen eines Image ist ein Fehler aufgetreten.
    16 Die Quelle wurde nicht gefunden, oder beim Öffnen der Quelle ist ein Fehler aufgetreten.
    18 Das Ziel wurde nicht gefunden, oder beim Öffnen des Ziels ist ein Fehler aufgetreten.

Beispiele:

  1. Die Datei W2k.img öffnen, die das das Kennwort 'develop' erfordert.
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop
  2. Zwei Image-Dateien öffnen, die verschiedene Kennwörter haben, 'password' und 'sales'.
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop f:\w2k.img -password sales
  3. Alle *.txt-Dateien in e:\ dem Ordner 'temp' des Datenträgers in Slot 1 von w2k.img hinzufügen.
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop -add e:\*.txt 1:\temp
  4. Die kernel.dll aus dem Ordner 'Windows' des Datenträgers 'sys' in w2k.img nach e:\dump extrahieren.
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop -add e:\*.txt 1:\temp
  5. Die Image-Datei im altem Format, w2k.img, in das neue Image, new2k.img, in 650-MB-Segmente konvertieren.
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -convert f:\new2k.img -size 650