Altiris® IMAGEEXPLORER 6.8 Ayuda

Altiris®
IMAGEEXPLORER 6.8
Ayuda


Aviso

ImageExplorer
© 2006 Altiris Inc. Reservados todos los derechos.
Fecha del documento: 21 de julio de 2006
Patente en Estados Unidos de Bootworks No. 5,764,593.
Patente en Estados Unidos de RapiDeploy No. 6.144.992.
Patente en Estados Unidos de Recovery Solution No. 5.778.395, 5.907.672, 4701745, 5016009, 5146221, 5144425, 5463390, 5506580, 5532694, GB 2172127, B 904359, 3606869.
Otras patentes pendientes.
Debido a la naturaleza inherentemente compleja del software, Altiris no garantiza que el software de Altiris esté libre de errores, funcione sin interrupciones, sea compatible con todas las configuraciones de equipos y software, o satisfaga de cualquier otro modo todas sus necesidades.
El contenido de esta documentación se proporciona únicamente a título informativo, está sujeto a cambios sin previo aviso y no se debe interpretar como un compromiso por parte de Altiris. Altiris Inc. no asume ninguna responsabilidad por errores o imprecisiones que puedan aparecer en esta documentación. Para obtener la documentación más reciente, visite nuestro sitio Web en www.altiris.com.
Altiris, el logotipo de Altiris, BootWorks, Eality, ImageBlaster, Inventory Solution, PC Transplant, RapiDeploy, RapidInstall y Visión son marcas comerciales registradas de Altiris, Inc. en Estados Unidos. Altiris, el logotipo de Altiris y ManageFusion son marcas comerciales registradas de Altiris, Inc. en otros países.
Altiris Connector, Altiris eXpress, Altiris Protect, Application Management Solution, Application Metering Solution, Asset Control Solution, Asset Management Suite, Carbon Copy, Client Management Suite, Compliance Toolkit, Connector Solution, Contract Management Solution, Deployment Server, Deployment Solution, Energy Saver Toolkit, Education Management Suite, FSLogic, Handheld Management Suite, Helpdesk Solution, Lab Management Suite, ManageFusion, Migration Toolkit, Mobile Client for SMS, Monitor Solution, Network Discovery, Notification Server, Package Importer, Patch Management Solution, Problem Management Suite, Recovery Solution, Security Solution, Server Management Suite, Site Monitor Solution, Software Delivery Solution, SNMP Management, Software Delivery Suite, TCO Management Solution, UNIX Client for SMS, Web Administrator, Web Reports y otros nombres de productos son marcas comerciales de Altiris, Inc. en Estados Unidos y otros países.
AuditExpress, Scan on Detect y SecurityExpressions son marcas comerciales de Pedestal Software Inc. en Estados Unidos. Audit on Connect y Audit on Detect son marcas comerciales de Pedestal Software Inc. en Estados Unidos y en otros países.
WebLens y Guaranteeing Your Net Works son marcas comerciales registradas de Tonic Software Inc. en Estados Unidos.
WebInsight y RUM son marcas comerciales de Tonic Software Inc. en Estados Unidos.
Microsoft, Windows y el logotipo de Windows son marcas comerciales o marcas comerciales registradas de Microsoft Corporation en Estados Unidos y otros países.
HP y Compaq son marcas comerciales registradas de Hewlett-Packard Corporation.
Dell es una marca comercial registrada de Dell Inc.
Macintosh es una marca comercial registrada de Apple Computer Corporation.
Palm OS es una marca comercial registrada de Palm Computing, Inc.
BlackBerry es una marca de servicio y comercial de Research In Motion Limited Corporation.
RIM es una marca de servicio y una marca comercial registrada de Research In Motion (RIM).
Los otros nombres de compañías, marcas o productos son o pueden ser marcas comerciales de sus respectivos propietarios.


Altiris ImageExplorer

Altiris ImageExplorer ofrece funciones para la visualización y edición de archivos de imagen. Los archivos de imagen se crean mediante la utilidad RapiDeploy, la cual es una herramienta que se utiliza comúnmente en Deployment Solution para crear y distribuir archivos de imagen de disco duro, es decir archivos IMG o EXE que contienen una réplica del disco duro del equipo de origen.

Con la ayuda de ImageExplorer podrá modificar un archivo de imagen, o sea agregar o eliminar archivos de datos, carpetas y aplicaciones, antes de distribuir o restaurar su contenido en un equipo cliente. Podrá consultar las propiedades y realizar operaciones, tales como extraer y guardar archivos en otro volumen de destino, o excluir archivos de la restauración al distribuir el archivo de imagen en un equipo cliente. También puede imprimir el contenido de una carpeta o editar un archivo a través de la aplicación asociada.

Consulte también: Uso de ImageExplorer

Funciones de ImageExplorer
  • Agregar archivos y carpetas nuevos
  • Modo de línea de comandos
  • Convertir imágenes
  • Crear índices de imagen
  • Extraer archivos y carpetas
  • Excluir o incluir volúmenes, carpetas y archivos en la restauración
  • Buscar archivos en una imagen
  • Abrir un archivo con el programa asociado para editarlo
  • Crear imágenes autoextraíbles
  • Imprimir la estructura de árbol de imagen de archivos, carpetas y volúmenes
  • Reemplazar archivos
  • Regresar al contenido original del archivo de imagen
  • Dividir imágenes
  • Ver, agregar o cambiar la descripción de la imagen
  • Ver las propiedades de los archivos, las carpetas y los volúmenes de una imagen
Interfaz de usuario de ImageExplorer

Haga clic en el icono ImageExplorer de la barra de herramientas o haga clic en Herramientas > ImageExplorer. Se abre el programa ImgExpl.exe ubicado en el recurso compartido Deployment.
Puede abrir y editar archivos de imagen en el tipo de archivo IMG nativo o archivos de imagen con versiones de tiempo de ejecución rdeploy.exe empaquetadas en el tipo de archivo EXE.

Altiris ImageExplorer ofrece las características siguientes para ver, administrar y modificar los elementos de volumen, carpeta y archivo de un archivo de imagen.

Característica
Descripción
Botón
Acceso
Agregar archivo
Agrega un archivo nuevo al archivo de imagen. (Ver Agregar nuevos archivos).
Agregar archivo está disponible si hace clic con el ratón secundario en un volumen, en una carpeta o en un archivo en la vista de árbol. Si hace clic con el botón secundario en un archivo y selecciona Agregar archivo, el archivo nuevo se agrega a la misma carpeta.

Opción 1: Ctrl-A
Opción 2: Haga clic en Editar > Agregar archivo
Opción 3: Haga clic con el botón secundario en un elemento y seleccione Agregar archivo
Agregar carpeta
Agrega una carpeta nueva al archivo de imagen. Haga clic en cualquier elemento para agregar una carpeta al objeto contenedor.
Agregar carpeta está disponible si hace clic con el ratón secundario en un volumen, en una carpeta o en un archivo en la vista de árbol.

Opción 1: Ctrl-D
Opción 2: Haga clic en Editar > Agregar carpeta
Opción 3: Haga clic con el botón secundario en un elemento y seleccione Agregar carpeta
Convertir imagen
Convierte los archivos de imagen del formato de archivo 4 al formato más comúnmente utilizado por RapidDeploy. (Ver Convertir imagen).
Opción 1: Ctrl-T
Opción 2: Haga clic en Archivo > Convertir imagen
Copia
Copia un archivo o carpeta de una ubicación y permite pegarlos en un archivo de imagen de destino.
Nota: La copia de grandes cantidades de datos y de una gran cantidad de archivos entre archivos de imagen podría tomar varios minutos.

Opción 1: Ctrl-C

o bien

Opción 2: Haga clic en Editar > Copiar

o bien

Opción 3: Haga clic con el botón secundario en un elemento y seleccione Copiar
Crear índice de imagen
Crea un índice de imagen para facilitar el proceso de restauración de imágenes. (Ver Crear índice de imagen).
Opción 1: Ctrl-I
Opción 2: Haga clic en Archivo > Crear índice de imagen
Excluir
Marca los volúmenes, las carpetas y los archivos que no se incluirán al desplegar el archivo de imagen en los equipos cliente.
Nota: Otra forma de excluir un archivo es al hacer clic en la casilla de verificación junto al archivo en el panel Detalles. El [image] icono reemplaza la casilla de verificación.

Opción 1: Tecla Supr

o bien

Opción 2: Haga clic en Editar > Excluir

o bien

Opción 3: Haga clic con el botón secundario y seleccione Excluir archivos
Extraer
Extrae un volumen, una carpeta (con sus subcarpetas) o un archivo completos de un archivo de imagen. Permite seleccionar un volumen o directorio de destino para guardar las carpetas o los archivos. (Ver Extraer una carpeta).
Nota: La extracción de grandes cantidades de datos y de una gran cantidad de archivos podría tomar varios minutos.

Opción 1: Ctrl-E

o bien

Opción 2: Haga clic en Editar > Extraer

o bien

Opción 3: Haga clic con el botón secundario en un elemento y seleccione Extraer archivos
Buscar
Busca archivos o carpetas en un archivo de imagen mediante nombres específicos o caracteres de comodín. Utilice ? en calidad de variable de un carácter individual o * (asterisco) para varios caracteres. (Ver Buscar archivos).

Opción 1: Ctrl-F

o bien

Opción 2: Haga clic en Editar > Buscar

Opción 3: Haga clic con el botón secundario en un objeto y seleccione Buscar
Incluir
Permite la inclusión de volúmenes, carpetas y archivos previamente marcados como Excluidos en un archivo de imagen al desplegar éste en un equipo cliente.
Nota: Otra forma de incluir un archivo previamente excluido consiste en hacer clic [image] junto al archivo en el panel Detalles. Aparece una casilla de verificación.

Opción 1: Tecla Ins

o bien

Opción 2: Haga clic en Editar > Incluir

o bien

Opción 3: Haga clic con el botón secundario en un elemento excluido y seleccione Incluir
Convertir en autoextraíble
Crea un archivo autoextraíble a partir de un archivo de imagen existente. (Ver Crear imágenes autoextraíbles).
Opción 1: Ctrl-M
Opción 2: Haga clic en Archivo > Convertir en autoextraíble
Abrir archivo
(disponible para los archivos)
Abre un archivo mediante una aplicación asociada, si la aplicación existe en el equipo en el cual se ejecuta ImageExplorer.

Opción 1: Doble clic

o bien

Opción 2: Haga clic en Editar > Abrir

o bien

Opción 3: Haga clic con el botón secundario en un archivo y seleccione Abrir
Abrir archivo con
Permite abrir un archivo con el programa seleccionado. Si el archivo ya está asociado a un programa, haga doble clic para abrirlo. Utilice Abrir archivo con para cambiar el programa o seleccionar la función de Apertura rápida.
Nota: Los archivos de imagen creados con IBMaster 4.5 no se abrirán. No obstante, puede utilizar la función Convertir imagen para convertir archivos de imagen al formato de archivo de RapiDeploy.
Opción 1: Haga doble clic (si no está asociado)

o bien

Opción 2: Haga clic en Editar > Abrir con

o bien

Opción 3: Haga clic con el botón secundario en el archivo y seleccione Abrir con
Abrir archivo de imagen
Abre los archivos de imagen creados con RDeploy.exe o con IBMaster.exe. Los archivos creados con IBMaster son de sólo lectura; no obstante, estos archivos pueden verse y extraerse. Necesita una versión anterior de ImageExplorer (Deployment Solution 5.5 o anterior, o RapiDeploy 4.5 o anterior) para editar los archivos creados con IBMaster.exe.

Opción 1: Ctrl-O

o bien

Opción 2: Haga clic en Archivo > Abrir
Pegar
Coloca un archivo o una carpeta de una ubicación a otra.

Opción 1: Ctrl-V

o bien

Opción 2: Haga clic en Editar > Pegar

o bien

Opción 3: Haga clic con el botón secundario en un elemento y seleccione Pegar
Imprimir
Carpetas: Imprime la estructura de carpeta. Incluye las subcarpetas y los archivos con el tamaño y la fecha y hora de modificación.

Archivos: Imprime el archivo. Debe tener instalado el programa de aplicación asociado para imprimir el archivo (por ejemplo, MS Word para imprimir archivos DOC).
Ver Imprimir contenidos de carpeta y Imprimir un archivo.

Opción 1: Ctrl-P

o bien

Opción 2: Haga clic en Archivo > Imprimir

o bien

Opción 3: Haga clic con el botón secundario en un elemento y seleccione Imprimir
Propiedades
Contiene información general sobre la carpeta o el archivo, tales como el tamaño, las fechas de modificación y los atributos. Las propiedades se muestran de forma distinta para las imágenes, los volúmenes, las carpetas o los archivos. Consulte Ver propiedades.

Opción 1: Alt-Intro

o bien

Opción 2: Haga clic en Archivo > Propiedades

o bien

Opción 3: Haga clic con el botón secundario en un elemento y seleccione Propiedades
Reemplazar archivos
(disponible para los archivos)
Proporciona una forma para actualizar un archivo en la imagen con un archivo de otro origen. Ambos archivos deben tener el mismo nombre.

Opción 1: Ctrl-L

o bien

Opción 2: Haga clic en Editar > Reemplazar

o bien

Opción 3: Haga clic con el botón secundario y seleccione Reemplazar archivos
Deshacer
(disponible para los archivos)
Función de deshacer para la opción Reemplazar archivo. Regresa al archivo cambiado al archivo original.

Opción 1: Ctrl-R

o bien

Opción 2: Haga clic en Editar > Deshacer

o bien

Opción 3: Haga clic con el botón secundario en un elemento y seleccione Deshacer archivos
Dividir imagen
Divide un archivo de imagen de un tamaño para que sea el tamaño de segmento de otro. (Ver Convertir imagen).
Opción 1: Ctrl-S
Opción 2: Haga clic en Archivo > Dividir imagen


Uso de ImageExplorer

Con ImageExplorer en ejecución, abra el archivo de imagen que desee ver o modificar. Para ello, seleccione Archivos > Abrir en la barra de menú del programa.

Nota: Los archivos de imagen anteriores creados con IBMaster.exe en lugar del archivo RDeploy.exe actual no se pueden modificar con la versión de ImageExplorer que se incluye con Deployment Solution 5.6 o superior. No obstante, los archivos de imagen creados con IBMaster se pueden ver y los archivos se pueden extraer. ImageExplorer siempre muestra los archivos creados con IBMaster como de sólo lectura aunque los atributos de archivo sean de lectura y escritura. Para modificar archivos de imagen anteriores debe utilizar la versión de Altiris ImageExplorer que se incluye con versiones anteriores de Deployment Solution.

Consulte también: Ver propiedades, Agregar nuevos archivos y Extraer una carpeta.


Ver propiedades

Tras abrir un archivo de imagen con ImageExplorer, puede ver la información básica sobre el archivo de imagen y sus elementos. Para ello, seleccione el nombre de un archivo o volumen (partición) y haga clic en Propiedades. Para abrir la página de propiedades de un archivo de imagen, de un volumen o de un archivo, haga clic con el botón secundario y seleccione Propiedades y haga clic en Archivo > Propiedades, o utilice las teclas Alt-Intro. Según el tipo de elemento de imagen, se abre una página de propiedades con las fichas correspondientes:


Propiedades generales de un archivo de imagen

Esta página muestra los datos de los archivos de imagen. Tras seleccionar Propiedades de un archivo de imagen, haga clic en la ficha General para ver los elementos de imagen y los datos de propiedad adicionales, tales como el tamaño, la ubicación y los atributos.

La página de propiedades de la imagen incluye el nombre del archivo de imagen y los datos de la imagen asociada. Ejemplo: El campo Tamaño muestra la cantidad de espacio que la imagen utiliza en la unidad de disco duro del equipo de origen. El campo Tamaño en el disco muestra el tamaño del archivo de imagen comprimido antes de su despliegue.

En este cuadro de diálogo puede modificar la contraseña del archivo de imagen.


Propiedades generales de un volumen

Esta página muestra los datos de un volumen. Tras seleccionar Propiedades de una carpeta seleccionada en un archivo de imagen, haga clic en la ficha General para ver las propiedades, tales como el tamaño, la ubicación y los atributos.


Propiedades generales de una carpeta

Esta página muestra los datos de una carpeta. Tras seleccionar Propiedades de un archivo de imagen, haga clic en la ficha General para ver los archivos incluidos y los datos de propiedad adicionales, tales como el tamaño, la ubicación y los atributos.


Propiedades generalesde archivos

Esta página muestra los datos de los archivos. Tras seleccionar Propiedades de una carpeta seleccionada de un archivo de imagen, haga clic en la ficha General para ver los archivos incluidos y los datos de propiedad adicionales, tales como el tamaño, la ubicación y los atributos.


Propiedades de descripción de una imagen

Esta página muestra los volúmenes componentes de un archivo de imagen. Contiene un conteo de los volúmenes de la imagen y muestra el nombre de cada volumen en el panel Volúmenes. Si el archivo de imagen tiene acceso de lectura y escritura, puede modificar la descripción de la imagen.


Propiedades de partición de disco

La página de propiedades Varios contiene una lista exhaustiva de los atributos de sistema de cada uno de los volúmenes del archivo de imagen. Incluye datos y estadísticas de volumen, los cuales incluyen datos importados de la tabla de particiones.


Abrir archivo

Para abrir un archivo de una imagen, haga doble clic en el archivo en el panel Detalles de ImageExplorer o haga clic con el botón secundario y seleccione Abrir. El archivo se abre con el programa asociado. Si no se encuentra el programa asociado, se muestra el cuadro de diálogo Abrir con, el cual permite que el usuario seleccione un programa y lo asocie al archivo.

Nota: Para asociar un archivo a un programa, haga clic con el botón secundario y seleccione el comando Abrir con.

La función de Apertura rápida permite seleccionar un programa predeterminado para abrir archivos sin programas asociados (el programa predeterminado es el Bloc de notas de Microsoft). Para cambiar el programa predeterminado de la función Apertura rápida, haga clic en Ver > Configuración y edite el cuadro Abrir con el programa.

Consulte también: Imprimir un archivo y Configuración.


Apertura de archivos de imagen dividida

Si una imagen es demasiado grande o si está tratando de seguir las restricciones de tamaño para almacenar una imagen (tal como la división de archivos de imagen en 600 MB para colocarlos en varios CD), utilice las funciones de RapiDeploy para dividir el archivo de imagen en varios archivos. Durante la edición, ImageExplorer lleva un control de los archivos de la imagen dividida y le pedirá que ubique cualquier archivo de imagen vinculado adicional no almacenado en el mismo directorio.


Búsqueda de archivos de imagen dividida faltantes

Si se mantienen los diversos archivos de una imagen dividida en carpetas o CD separados, este cuadro de diálogo se abre para ayudarle a buscar los archivos de imagen dividida faltantes. Escriba una ruta en el campo o vaya a los archivos faltantes. ImageExplorer lleva un control de todos los archivos de una imagen dividida y le indica si existen archivos de imagen dividida faltantes que no se encuentren en la misma carpeta.


Agregar nuevos archivos

  1. Abra Altiris ImageExplorer.
  2. Haga clic en Archivo > Abrir. Seleccione un archivo de imagen.
  3. Haga clic en Aceptar.
  4. Haga clic con el botón secundario en el volumen o la carpeta deseado en la imagen y seleccione Agregar archivo. Se abre el cuadro de diálogo Seleccionar los archivos a agregar.

Opción 1:

    • Ubique un archivo y haga clic en Aceptar. El archivo nuevo se muestra en la imagen.

      • Opción 2:

    • Arrastre un archivo del Explorador de Windows a la carpeta o el volumen seleccionado en el archivo de imagen mostrado en ImageExplorer o copie y pegue el archivo. Si se ha seleccionado la opción (consulte las operaciones de pegar y soltar del cuadro de diálogo Configuración), aparece un cuadro de mensaje que confirma su decisión de copiar un archivo al archivo de imagen.

Nota: Para acceder y editar archivos de texto, haga doble clic en el archivo en el panel Detalles del cuadro de diálogo ImageExplorer.


Convertir imagen

El formato de archivo interno de las imágenes ha cambiado del formato de archivo 4 de Deployment Server versión 5.5 y anterior, al formato de archivo 6 de Deployment Server 5.6 o posterior. El formato de archivo 6 ha permanecido igual desde su lanzamiento. No obstante, se han realizado cambios menores a fin de mejorar la estructura global del formato.

Esta función permite seleccionar archivos de imagen creados anteriormente y convertirlos al formato de archivo que RapidDeploy utiliza actualmente. Si el formato de archivo cambia en versiones futuras de Deployment Server, al convertir un archivo de imagen siempre se convertirá al formato de archivo más reciente.

Al convertir archivos de imagen, tome nota de lo siguiente:

  • Si una imagen antigua tiene un archivo de índice de imagen (imx), se crea un nuevo archivo de índice de imagen.
  • Si un archivo de imagen antiguo es una imagen autoextraíble, se elimina el código de RapidDeploy integrado y se restaura la imagen a un archivo .img. No recibirá un mensaje de advertencia sobre la eliminación del código autoextraíble integrado.
  • Si una imagen antigua tiene una contraseña, el nuevo archivo de imagen creado no tiene contraseña. No obstante, el usuario recibe un mensaje que indica que se ha eliminado la contraseña.
  • El tiempo que toman las conversiones de archivo podría variar debido a que ImageExplorer lee cada segmento de la imagen antes de convertirlo a un archivo de imagen nuevo. Tomará más tiempo si se procesan archivos de gran tamaño con varios segmentos.
Definiciones de campo

Archivo de imagen que se convertirá Seleccione el archivo de imagen que desee convertir.

Tamaño actual del segmento: De forma predeterminada, el tamaño de segmento de las imágenes de RapiDeploy es de 2 GB.

Recuento actual de segmento: Cantidad de segmentos del archivo de imagen.

Nuevo archivo de imagen de salida: Seleccione una carpeta y un nombre de archivo para el archivo de imagen que desee convertir, según el nuevo tamaño de segmento.

Nuevo tamaño de segmento (MB): Seleccione una tamaño para los segmentos de imagen en la lista desplegable. La lista de opciones incluye los tamaños predeterminados de los CD, unidades zip, etc. Si un segmento de archivo alcanza este límite, se crea un nuevo segmento hasta que se haya convertido toda la imagen.

Recuento estimado de segmento: Cantidad estimada de segmentos del archivo de imagen que ha seleccionado para la conversión.

Para convertir un archivo de imagen
  1. Haga clic en Archivo y seleccione Convertir archivo de imagen.
  2. Haga clic en Examinar para ir a la carpeta y seleccione un archivo de imagen que convertir.
  3. Haga clic en Examinar para ir a la carpeta. Escriba un nuevo nombre de archivo para la imagen convertida.
  4. Haga clic en la flecha desplegable y seleccione un tamaño de segmento en la lista.
  5. Haga clic en Aceptar.


Crear índice de imagen

Esta función permite crear un archivo de índice para los archivos de imagen para que al copiar las imágenes a CD, el archivo de índice, junto con el primer segmento de la imagen, den información sobre al archivo a RapiDeploy al restaurar el archivo de imagen.

Ejemplo: Si tiene una imagen con varios segmentos, tales como .img, .002, .003 y .004, ImageExplorer crea una tabla de contenido al final del segmento .004, la cual identifica la información de archivo de cada segmento de la imagen.

Con esta función, se crea un nuevo archivo de índice de nombre .imx. Luego, al copiar los segmentos a CD, puede seleccionar .img e .imx para que estén en el mismo CD. Los otros segmentos, .002, .003 y .004 se pueden copiar a los CD adicionales como sea necesario. Al utilizar los CD para restaurar una imagen, el primer CD que contiene los archivos .img e .imx da a RapiDeploy la información necesaria para restaurar la imagen. Esto facilita la restauración de imágenes debido a que no es necesario insertar el primer CD, el último CD y luego el primer CD de nuevo a fin de que RapiDeploy restaure la imagen.

Para indexar las imágenes a medida que las crea, seleccione la opción Crear un archivo de índice de imagen (.imx) en RapiDeploy. Consulte la Guía de referencia de RapiDeploy.

Definiciones de campo

Archivo de imagen que se indexará: Seleccione el archivo de imagen que desee indexar.

Carpeta de salida para el índice (opcional): Si no selecciona una carpeta para la salida del índice, el archivo .imx se crea en la misma carpeta en la que se encuentra la imagen que ha seleccionado para la indexación.

Para crear el índice de una imagen
  1. Haga clic en Archivo y seleccione Crear índice de imagen.
  2. Haga clic en Examinar para ir a la carpeta y seleccione un archivo de imagen.
  3. Haga clic en Examinar para ir a la carpeta de salida del archivo de índice.
  4. Haga clic en Aceptar.


Extraer una carpeta

Utilice esta función para tomar una carpeta o un archivo de una imagen y guardarlo en una carpeta de destino externa:

  1. Abra Altiris ImageExplorer.
  2. Haga clic en Archivo > Abrir. Seleccione un archivo de imagen.
  3. Haga clic en Aceptar.
  4. Seleccione una carpeta en la imagen, haga clic con el botón secundario y seleccione Extraer carpeta. Se abre el cuadro de diálogo Examinar.
  5. Seleccione una carpeta en el disco local o en la red para colocar la carpeta extraída.
  6. Haga clic en Aceptar.

Nota: La extracción de grandes cantidades de datos y de una gran cantidad de archivos podría tomar varios minutos.


Buscar archivos

Para buscar archivos o carpetas en un archivo de imagen, escriba una cadena o caracteres alfabéticos y numéricos en el cuadro Buscar. Utilice ? (signo de interrogación) en calidad de variable de un carácter individual o * (asterisco) para varios caracteres.

Para buscar un archivo, seleccione el archivo de imagen, el nombre del volumen o el nombre de la carpeta en la vista de árbol a fin de definir un dominio de búsqueda. Puede cambiar el dominio de búsqueda antes de hacer clic en Buscar.

Definiciones de campo

Incluir carpetas: Seleccione esta opción para incluir carpetas que coincidan en los resultados de la búsqueda.

Incluir archivos: Seleccione esta opción para incluir archivos que coincidan en los resultados de la búsqueda.

Los archivos y las carpetas que cumplen con el criterio de búsqueda especificado se muestran en el cuadro de resultados, organizados por Nombre de archivo y Ubicación.


Filtrar resultados

Haga clic en Filtro en el cuadro de diálogo Buscar archivos para abrir una búsqueda avanzada de archivos según atributos de sistema asociados (sólo lectura, oculto, sistema) y atributos de ImageExplorer (agregado, excluido, reemplazado).

Definiciones de campo

Buscar: Escriba la cadena o los caracteres para buscar un archivo según atributos de sistema o de ImageExplorer del archivo o carpeta. Haga clic en Incluir archivos coincidentes para seleccionar los archivos. Haga clic en Incluir carpetas coincidentes para seleccionar los carpetas.

Nota: Para buscar en un directorio especificado, selecciónelo en el panel de vista de árbol y abra el cuadro de diálogo Buscar.

Los atributos siguientes utilizan casillas de verificación tridireccionales con estas funciones:

  • Una marca de verificación sólida indica que el elemento debe contener el atributo.
  • Un cuadro vacío indica que el elemento no debe contener el atributo.
  • Una marca de verificación atenuada indica que el valor es NULO y que el elemento puede o no tener el valor.

Atributos: Son los atributos de sistema de los archivos asignados por el sistema operativo cuando se creó la imagen.

Indicadores: Estos atributos son asignados por ImageExplorer.


Crear imágenes autoextraíbles

Permite crear un archivo autoextraíble de un archivo de imagen existente para que pueda ejecutar el archivo ejecutable en un equipo cliente. Resulta útil si necesita restaurar una imagen en un equipo que no tiene acceso al Deployment Server ni a RapidDeploy para la creación de imágenes a través de la red.

Puede seleccionar archivos de imagen que hayan sido creados con RapiDeploy, el cual se ha utilizado para crear imágenes a partir de Deployment Server 5.6 o posterior. Si posee imágenes que fueron creadas con Altiris IBMaster 4.5 o anterior, no podrá utilizar esta función. No obstante, si va a una carpeta para seleccionar una imagen, se muestran todos los archivos .img. Puede utilizar la función Convertir imagenpara convertir la imagen al formato de archivo de RapiDeploy más reciente.

El archivo autoextraíble está compuesto de un archivo de imagen válido y de RapiDeploy, el cual se integra en el archivo ejecutable. Puede copiar el archivo autoextraíble en una carpeta o medio extraíble y ejecutarlo de forma manual en cualquier equipo o bien, puede crear una tarea de despliegue en el Deployment Server y distribuir el archivo autoextraíble en varios equipos.

Cuando estén disponibles versiones nuevas de RapiDeploy a través de las actualizaciones de Deployment Server, puede volver a crear cualquier archivo autoextraíble mediante la ejecución de Convertir en autoextraíble. El código de RapiDeploy integrado en el archivo de imagen se reemplaza con la versión más reciente de RapiDeploy.

El tiempo que toma este proceso podría variar debido a que ImageExplorer lee solamente el segmento .img. Si el archivo tiene 2 GB, tomará más tiempo que si el segmento .img tiene 700 MB.

RapidDeploy y solamente el primer segmento del archivo de imagen (.img) se combinan para crear el archivo ejecutable que restaura las imágenes. Sin embargo, todos los demás segmentos que componen la imagen en su totalidad, incluso el índice (.imx), son necesarios al restaurar la imagen.

Consulte también: Vea Crear índice de imagen

Definiciones de campo

Tipo autoextraíble actual: El archivo de imagen que ha seleccionado tiene este tipo de sistema operativo.

Mantener el archivo de imagen original: Seleccione esta casilla de verificación para que ImageExplorer cree un archivo de imagen autoextraíble sin afectar el archivo de imagen original.

Nota: Si desmarca esta casilla de verificación y falla el proceso de Convertir en autoextraíble, el archivo de imagen original podría dañarse o deteriorarse y no podrá utilizarlo para crear un archivo autoextraíble.

Tamaño de archivo de imagen: Tamaño de la imagen seleccionada.

Eliminar el autoextraíble existente: Utilice esta opción para eliminar el código .exe de una imagen autoextraíble. El archivo de imagen regresa al estado original con la extensión de archivo .img. Esta opción solamente está disponible si el archivo de imagen tiene código autoextraíble, caso contrario, la opción no está disponible.

DOS: Este modo utiliza la interfaz gráfica de usuario de RapiDeploy para mostrar el progreso del archivo de imagen mientras está en ejecución.

Modo texto DOS: Interfaz de usuario de versión de texto. Puede ver la barra de progreso en la parte inferior de la pantalla del equipo cliente mientras esté en ejecución el archivo de imagen.

Para crear un archivo de imagen autoextraíble
  1. Haga clic en Archivo y seleccione Convertir en autoextraíble.
  2. Haga clic en Examinar para buscar la ubicación del archivo de imagen.
  3. Desmarque la opción Mantener el archivo de imagen original si desea convertir el archivo de imagen original en archivo autoextraíble.
  4. Seleccione la opción Cambiar tipo autoextraíble. (Ver Definiciones de campo).
  5. Haga clic en Aceptar. El archivo autoextraíble se crea en el mismo directorio que el archivo de imagen original. Si se abre el cuadro de diálogo No hay suficiente espacio en disco, consulte No hay suficiente espacio en disco.


No hay suficiente espacio en disco

El archivo de imagen que ha seleccionado para convertir en archivo autoextraíble no se puede crear debido a que no hay suficiente espacio en disco. El cuadro de diálogo No hay suficiente espacio en disco permite seleccionar una ubicación alternativa para crear el archivo autoextraíble. Escriba una ruta de directorio o haga clic en el botón Explorar para ir a la ubicación con más espacio de disco. Haga clic en Aceptar.


Imprimir contenidos de carpeta

Puede imprimir una lista de archivos y subcarpetas de un archivo de imagen, un volumen (partición) o una carpeta. Según las opciones seleccionadas, puede imprimir un informe que incluya los archivos y las carpetas componentes y que incluya campos con los atributos modificados de fecha, hora, tamaño, etc. de cada archivo.

Al imprimir el contenido de un archivo, volumen o carpeta de imagen, haga clic en Aceptar para ver una Vista preliminar del archivo de informe.

Definiciones de campo

Título: Escriba un título para la parte superior de la página de informe.

Qué imprimir

Sólo esta carpeta: Imprime solamente los archivos de la imagen, el volumen o la carpeta que se ha seleccionado. No imprime las subcarpetas.

Esta carpeta y todas las subcarpetas: Imprime los archivos de la imagen, el volumen o la carpeta que se ha seleccionado, al igual que todas las subcarpetas y archivos.

Imprimir elementos excluidos: Imprime los archivos que se marcaron anteriormente como Excluidos.

Imprimir entradas < . >: Imprime una entrada en cada carpeta identificada como < . > (notación de punto). Los atributos y las propiedades de fecha y hora de esta carpeta oculta se guardan en el archivo de imagen.

Campos que se imprimirán

Incluir fecha / hora de modificación: Imprime la fecha y la hora en que se modificó el archivo o la carpeta.

Incluir tamaño: Imprime el tamaño del archivo.

Incluir atributos: Imprime los atributos de sistema Sólo lectura, Archivar, Oculto, Sistema o Comprimido (sólo lectura, sistema, oculto) y los atributos de ImageExplorer (agregado, excluido, reemplazado).

Incluir números de archivos: Imprime el número de archivo asociado con cada archivo.

Consulte también: Imprimir un archivo.


Vista preliminar

Vea una versión en línea del informe impreso con los archivos, volúmenes o carpetas de imagen. El nombre del informe aparece en la parte superior de la página con detalles en una tabla, los cuales se seleccionaron en el cuadro de diálogo Imprimir contenidos de carpeta.

Definiciones de campo

Guardar: Haga clic para guardar el informe en un archivo de texto.

Líneas: Muestra la cantidad de líneas del informe.

Imprimir: Haga clic para imprimir el informe.


Imprimir un archivo

En el cuadro de diálogo ImageExplorer puede seleccionar e imprimir un archivo mediante el programa asociado. Si el archivo no está asociado a un programa, puede asociarlo. Para ello, seleccione un programa en la lista proporcionada de programas instalados en el equipo. También puede intentar una Impresión rápida para abrir el archivo mediante un programa estándar, tal como el Bloc de notas.

Definiciones de campo

Impresión rápida: Haga clic en este botón a fin de ejecutar un programa predeterminado para abrir o imprimir el archivo seleccionado. El programa predeterminado es el Bloc de notas de Microsoft. Puede cambiar el programa predeterminado para imprimir el archivo con el cuadro Imprimir con programa del cuadro de diálogo Configuración.

Consulte también: Imprimir contenidos de carpeta y Abrir archivo.


Establecimiento de la contraseña de un archivo de imagen

Haga clic con el botón secundario en un archivo de imagen y seleccione Propiedades. En la sección Atributos, seleccione Contraseña. Se abre el cuadro de diálogo Establecer o cambiar la contraseña.

Definiciones de campo

Contraseña actual: Escriba la contraseña actual.

Contraseña nueva: Escriba la contraseña nueva.

Confirmar contraseña: Escriba la contraseña de nuevo para confirmar que se ha escrito correctamente.


Configuración

Para establecer las preferencias de Altiris ImageExplorer, haga clic en Ver > Configuración. Se abre el cuadro de diálogo Configuración, en el cual puede establecer las opciones para confirmar las operaciones específicas mediante cuadros de mensaje en la interfaz de usuario, para establecer opciones de visualización o exclusión de elementos, o para seleccionar los programas predeterminados al utilizar las opciones Impresión rápida (consulte Imprimir un archivo) o Apertura rápida (consulte Abrir archivo).

Confirmaciones

Operaciones de apertura de sólo lectura: Presenta un mensaje de confirmación al usuario si se abre un archivo con el estado sólo lectura y como resultado no se puede guardar ningún cambio. Ejemplo: si se abre un archivo de imagen creado con RapiDeploy 4.5 o anterior, será de sólo lectura y no se podrá guardar ninguna operación realizada. Debido a esto, al abrir dicho archivo se abre un cuadro de confirmación que indica al usuario que no se puede guardar el archivo.

Operaciones de sobrescritura de archivo: Presenta un mensaje de confirmación al usuario al extraer un archivo de un archivo de imagen el cual sobrescribe un archivo existente en una unidad de destino.

Operaciones de deshacer en archivos: Presenta un mensaje de confirmación al ejecutar una operación de deshacer que devuelve el archivo de imagen a la estructura y el contenido de archivo originales tras reemplazar archivos.

Operaciones de pegar y soltar: Presenta un mensaje de confirmación al arrastrar un archivo a una carpeta nueva de un archivo de imagen, al utilizar la operación de copiar y pegar para mover archivos a otra carpeta o al utilizar el comando Agregar nuevos archivos.

Operaciones de exclusión: Presenta un mensaje de confirmación al usuario al asignar la opción de exclusión a un archivo (para que no se distribuya el archivo seleccionado como parte de la imagen). Este mensaje aparece al hacer clic en la casilla de verificación del archivo o de la carpeta o al seleccionar la operación de exclusión.

Operaciones de sobrescritura de carpeta: Presenta un mensaje de confirmación al usuario al extraer una carpeta de un archivo de imagen la cual sobrescribe una carpeta existente en una unidad de destino.

Mostrar configuración

Mantener el archivo arriba: Seleccione esta opción para abrir el archivo de ayuda encima de la interfaz de usuario de ImageExplorer. Permite ver la ayuda de forma paralela al programa en lugar de permitir que se envíe detrás de la interfaz de usuario de ImageExplorer.

Mostrar números de archivos: Muestra los números de archivos asociados en la imagen. En NTFS los archivos se numeran de forma automática. En FAT, EXT2, EXT3 y en otros sistemas de archivos, éstos son numerados por RapiDeploy al crear el archivo de imagen.

Mostrar elementos excluidos: Muestra los archivos marcados como excluidos en la imagen. Los archivos se muestran tras actualizar la pantalla.

Extraer elementos excluidos: Permite que los archivos y las carpetas excluidos se extraigan de la imagen a una carpeta de destino. Esta opción permite incluir todos los archivos previamente marcados como excluidos para guardarlos en una carpeta de destino externa al ejecutar el comando de extracción.

Colorear elementos agregados: Seleccione esta opción para marcar los archivos y las carpetas agregados a la imagen con texto de color azul. Ver Agregar archivo y Agregar carpeta.

Colorear elementos reemplazados: Seleccione esta opción para marcar los archivos y las carpetas reemplazados en la imagen con texto de color magenta. (Ver Reemplazar archivos (disponible para los archivos)).

Colorear elementos excluidos: Seleccione esta opción para marcar los archivos y las carpetas agregados a la imagen con texto de color rojo. (Ver Excluir).

Programas predeterminados para abrir e imprimir archivos

Estas opciones son la configuración predeterminada de las opciones de Apertura rápida y de Impresión rápida que aparecen con las funciones Abrir con y Abrir. Utilice estas opciones para asociar archivos a un programa común, tal como el Bloc de notas de Microsoft.

Abrir con el programa: Establece el programa predeterminado que se ejecuta con un archivo seleccionado. El programa predeterminado es el Bloc de notas de Microsoft. (Ver Abrir archivo).

Imprimir con el programa: Establece el programa predeterminado con el que se imprime un archivo seleccionado. El programa predeterminado es el Bloc de notas de Microsoft. (Ver Buscar archivos).


Dividir imagen

Esta función permite seleccionar un archivo de imagen para dividirlo (o reescribirlo) en un archivo de imagen nuevo según el tamaño de segmento que seleccione. Mientras que la función Convertir imagen cambia el formato de archivo de una imagen al formato actual utilizado por RapiDeploy, la división de la imagen mantiene el formato de la imagen original pero cambia el tamaño de los segmentos.

Ejemplo: si tiene un archivo de imagen de 2 GB y desea dividir la imagen para que quepa en CD, debe seleccionar un tamaño de segmento nuevo de 650 MB o 700 MB y el resultado será 1 archivo de imagen con varios segmentos. A continuación, puede copiar los segmentos a CD y utilizarlos para restaurar el archivo de imagen en los equipos cliente.

Al dividir archivos de imagen, tome nota de lo siguiente:

  • Si la imagen anterior es una imagen de formato antiguo (IBMaster 4.5 o anterior), la imagen no se puede dividir pero se puede convertir. Si esto sucede, se muestra un mensaje que verifica lo que desee hacer. Si continúa, se aplican todos los principios de Conversión e imagen.
  • Si una imagen antigua tiene un archivo de índice de imagen (imx), se crea un nuevo archivo de índice de imagen.
  • Si un archivo de imagen antiguo es una imagen autoextraíble, se conserva el código de RapidDeploy integrado y la nueva imagen contiene la misma versión de RapiDeploy que cuando se creó originalmente. No obstante, si la imagen es de formato antiguo (IBMaster 4.5 o anterior), la imagen no se puede dividir pero se puede convertir. Si continúa, se elimina el código autoextraíble.
  • Si una imagen antigua tiene una contraseña, el nuevo archivo de imagen tendrá la misma contraseña. Sin embargo, si la imagen es de formato antiguo (IBMaster 4.5 o anterior), la imagen no se puede dividir pero se puede convertir. Si continúa, se elimina la contraseña.
Definiciones de campo

Archivo de imagen que se dividirá: Seleccione el archivo de imagen que desee dividir.

Tamaño actual del segmento: De forma predeterminada, el tamaño de segmento de las imágenes de RapiDeploy es de 2 GB.

Recuento actual de segmento: Cantidad de segmentos del archivo de imagen.

Nuevo archivo de imagen de salida: Seleccione una carpeta y un nombre de archivo para el archivo de imagen que desee dividir.

Nuevo tamaño de segmento (MB): Seleccione una tamaño para los segmentos de imagen en la lista desplegable. La lista de opciones incluye los tamaños predeterminados de los CD, unidades zip, etc. Si un segmento de archivo alcanza este límite, se crea un nuevo segmento hasta que se haya dividido toda la imagen.

Recuento estimado de segmento: Cantidad estimada de segmentos del archivo que seleccionó para la división, en función del nuevo tamaño de segmento.

Para dividir un archivo de imagen
  1. Haga clic en Archivo y seleccione Dividir archivo de imagen.
  2. Haga clic en Examinar para ir a la carpeta y seleccione un archivo de imagen que dividir.
  3. Haga clic en Examinar para ir a la carpeta y escriba un nombre de archivo nuevo para la imagen.
  4. Haga clic en la flecha desplegable y seleccione un tamaño de segmento en la lista.
  5. Haga clic en Aceptar.


Modificadores de la línea de comandos

Esta función se puede utilizar para crear secuencias de comandos de ejecución o trabajos por lotes en Deployment Server para ayudar a administrar las imágenes desde la línea de comandos. Al final de algunos modificadores se muestran opciones selectas que indican que se permiten comandos adicionales.

Para el acceso a las opciones de línea de comandos en línea
  1. En el entorno de Windows, haga clic en Inicio > Ejecutar.
  2. Escriba el comando CMD en el campo Abrir.
  3. Escriba C:\Archivos de programa\Altiris\eXpress\Deployment Server\ (ruta de instalación predeterminada).
  4. Escriba imgexpl /? para abrir la página de modificadores de la línea de comandos.
    Línea de comandos
    Descripción
    Parámetros
    Archivos de imagen que abrir u operar (se puede repetir, tales como w2k.img, xp.img).
    Conmutadores
    -register: registra tipos de archivos en el registro de Windows.
    -unregister: anula el registro de tipos de archivos en el registro de Windows.
    -add <src> <dst>: agrega un archivo, una carpeta o un volumen a la imagen. Acepta la opción
    <-overwrite>. Puede utilizar comodines al escribir el origen (src).
    -extract <scr> <dst>: extrae un archivo, una carpeta o un volumen de la imagen. Acepta las opciones <-overwrite> y <-size>.
    -convert <dst>: convierte una imagen de formato antiguo al formato de imagen actual utilizado por RapiDeploy. Acepta las opciones <-overwrite> y <-size>.
    -split <dst>: divide una imagen en segmentos de archivo de un nuevo tamaño. Acepta las opciones <-overwrite> y <-size>.
    Opciones
    -lang <código de idioma>: *especifique el código de idioma de la interfaz de usuario.
    -silent: *no muestra confirmaciones ni errores.
    -password <contraseña>: *contraseñas de los archivos de imagen que se están abriendo.
    -overwrite: si se utiliza el modo silencioso, no confirma las acciones.
    -size <tamaño en MB>: tamaño del nuevo segmento de imagen en MB.
    * Indica las opciones que se pueden utilizar con cualquier comando.
    Códigos de salida de procesos
    0 Satisfactorio.
    2 Error de sintaxis de línea de comandos.
    4 Error al registrar o anular el registro de tipos de archivos.
    6 Operación cancelada por el usuario.
    8 Se intentó escribir en una imagen de sólo lectura.
    10 Contraseña no válida.
    12 Error al realizar una operación.
    14 El archivo de imagen no se encontró o se produjo un error al abrir la imagen.
    16 El archivo de origen no se encontró o se produjo un error al abrir el origen.
    18 El archivo de destino no se encontró o se produjo un error al abrir el destino.

Ejemplos:

  1. Abra el archivo W2k.img que requiera la contraseña `desarrollo'.
    • C:\Archivos de programa\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password desarrollo
  2. Abra dos archivos de imagen cada uno con una contraseña distinta: `clave' y `ventas'.
    • C:\Archivos de programa\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password clave f:\w2k.img -password ventas
  3. Agregue todos los archivos *.txt de e:\ a la carpeta `temp' del volumen en la ranura 1 de w2k.img.
    • C:\Archivos de programa\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password desarrollo -add e:\*.txt 1:\temp
  4. Extraiga kernal.dll de la carpeta `Windows' del volumen `sys' en w2k.img a e:\dump.
    • C:\Archivos de programa\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password desarrollo -add e:\*.txt 1:\temp
  5. Convierta el archivo de imagen de formato antiguo, w2k.img, a la nueva imagen, new2k.img, en segmentos de 650 MB.
    • C:\Archivos de programa\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -convert f:\new2k.img -size 650