Altiris(R) IMAGEEXPLORER 6.8 ヘルプ

Altiris(R)
IMAGEEXPLORER 6.8
ヘルプ


注意

ImageExplorer
(C) 2006 Altiris Inc. All rights reserved.
マニュアル作成日: 8 ２９, ２００６
Bootworks U.S. Patent No. 5,764,593.
RapiDeploy U.S. Patent No. 6,144,992.
Recovery Solution U.S. Patent No. 5,778,395, 5,907,672, 4701745, 5016009, 5146221, 5144425, 5463390, 5506580, 5532694, GB 2172127, B 904359, 3606869.
他の特許出願中。
コンピュータ ソフトウェアの本質的複雑性のため、Altiris 社は、当社のソフトウェアにエラーも中断もなく、すべての装置およびソフトウェアと互換性があり顧客のニーズを満たすものである、ということを保証するものではありません。
このマニュアルの内容は情報提供目的でのみ公開されており、Altiris 社の責務と解釈されるものではありません。また、内容は予告なしに変更されることがあります。Altiris Inc. は、この文書内の誤りや不正確な情報について、いかなる責任も法的義務も負わないものとします。最新のマニュアルについては、当社の Web サイトwww.altiris.com を参照してください。
Altiris、Altiris のロゴ、BootWorks、Eality、ImageBlaster、Inventory Solution、PC Transplant、RapiDeploy、RapidInstall、および Vision は、米国 Altiris, Inc. の登録商標です。Altiris、Altiris のロゴ、および ManageFusion は、他の国で Altiris, Inc. の登録商標です。
Altiris Connector、Altiris eXpress、Altiris Protect、Application Management Solution、Application Metering Solution、Asset Control Solution、Asset Management Suite、Carbon Copy、Client Management Suite、Compliance Toolkit、Connector Solution、Contract Management Solution、Deployment Server、Deployment Solution、Energy Saver Toolkit、Education Management Suite、FSLogic、Handheld Management Suite、Helpdesk Solution、Lab Management Suite、ManageFusion、Migration Toolkit、Mobile Client for SMS、Monitor Solution、Network Discovery、Notification Server、Package Importer、Patch Management Solution、Problem Management Suite、Recovery Solution、Security Solution、Server Management Suite、Site Monitor Solution、Software Delivery Solution、SNMP Management、Software Delivery Suite、TCO Management Solution、UNIX Client for SMS、Web Administrator、Web Reports、およびその他の製品名は、米国および他の国で Altiris,Inc. の商標です。
AuditExpress、Scan on Detect、および SecurityExpressions は、米国での Pedestal Software Inc. の商標です。Audit on Connect および Audit on Detect は、米国およびその他の国での Pedestal Software Inc. の商標です。
WebLens と Guaranteeing Your Net Works は、米国 Tonic Software Inc. の登録商標です。
WebInsight および RUM は、米国 Tonic Software Inc. の商標です。
Microsoft、Windows および Windows ロゴは米国あるいは他の国々で Microsoft Corporation の商標または登録商標です。
HP および Compaq は、Hewlett-Packard Corporation の登録商標です。
Dell は、Dell Inc の登録商標です。
Macintosh は、Apple Computer Corporation の登録商標です。
Palm OS は、Palm Computing, Inc. の登録商標です。
BlackBerry は、Research In Motion Limited Corporation のサービス マークおよび登録商標です。
RIM は、Research In Motion (RIM) のサービス マークおよび商標です。
その他の会社名、商品名または製品名は、それぞれの所有者の商標です。


Altiris ImageExplorer

Altiris ImageExplorer はイメージ ファイルの表示と編集機能を提供します。イメージ ファイルは、配布元コンピュータのハード ディスクの複製を含む IMG または EXE ファイルであり、Deployment Solution でハード ディスク イメージ ファイルの作成と配布を行うために最もよく使用されるツールである RapiDeploy を使用して作成します。

ImageExplorer を使用すれば、クライアント コンピュータに配布および復元する前に、データ ファイル、フォルダ、アプリケーションの追加または削除などといった、イメージファイルの編集が行えます。プロパティを表示して、他の配布先ボリュームにファイルを展開して保存したり、クライアント コンピュータにイメージ ファイルを配布する際にファイルを復元から除外するなどの操作を実行することが可能です。また、フォルダ内容の印刷や、関連アプリケーションを使用したファイル編集もできます。

関連項目: ImageExplorerの使用方法

ImageExplorer の機能
  • 新規ファイルとフォルダの追加
  • コマンド ライン モード
  • イメージの変換
  • イメージの索引の作成
  • ファイルとフォルダの展開
  • 復元対象からボリューム、フォルダ、およびファイルを除外（または含める）
  • イメージ内のファイルの検索
  • ファイルを関連付けられたプログラムから開き、編集
  • 自己展開イメージの作成
  • ファイル、フォルダおよびボリュームのイメージ ツリー構造の印刷
  • ファイルの置換
  • オリジナルのイメージファイルの内容へ戻す
  • イメージの分割
  • イメージの説明の表示、追加または変更
  • イメージ内のファイル、フォルダおよびボリュームのプロパティの表示
ImageExplorer ユーザ インタフェース

ツールバーの ImageExplorer アイコンをクリックするか、または[ツール]> [ImageExplorer]をクリックしてください。これで、Deployment Share にある ImgExpl.exe プログラムが開きます。
ネイティブ IMG ファイル タイプのイメージファイル、または EXE ファイルタイプのパッケージ化された rdeploy.exe ランタイム バージョンのイメージファイルを開く、あるいは編集することができます。

Altiris ImageExplorer は、イメージ ファイルのボリューム、フォルダ、およびファイル要素の表示、管理または変更を可能にする次の機能を提供します。

機能
説明
ボタン
アクセス方法
[ファイルの追加]
イメージファイルに新規ファイルを追加します。新規ファイルの追加を参照してください。
[ファイルの追加] は、ツリー表示でボリューム、フォルダまたはファイルを右クリックすると利用可能になります。ファイルを右クリックして [ファイルの追加]を選択すると、新規ファイルが同じファルダに追加されます。

オプション 1:Ctrl + A
オプション 2:[編集] > [ファイルの追加] をクリックします。
オプション 3:項目を右クリックして [ファイルの追加] を選択します。
[フォルダの追加]
イメージファイルに新規フォルダを追加します。任意の項目をクリックして、コンテナ オブジェクトにフォルダを追加します。
[フォルダの追加] は、ツリー表示でボリューム、フォルダまたはファイルを右クリックすると利用可能になります。

オプション 1:Ctrl + D
オプション 2:[編集] > [フォルダの追加] をクリックします。
オプション 3:項目を右クリックして [フォルダの追加] を選択します。
イメージの変換
イメージ ファイルをファイル フォーマット 4 から RapiDeploy で現在最も使用されているフォーマットに変換します。イメージの変換を参照してください。
オプション 1:Ctrl + T
オプション 2:[ファイル] > [イメージの変換] をクリックします。
[コピー]
あるロケーションからファイルまたはフォルダをコピーして、配布先イメージファイルへ貼り付けることができます。
注意: イメージ ファイル間で大量のデータおよび多数のファイルをコピーすると数分かかることがあります。

オプション 1:Ctrl + C

Ç<Ç¾ÇÕ

オプション 2:[編集] > [コピー] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:項目を右クリックして [コピー] を選択します。
イメージの索引 (IMX) の作成
イメージの索引を作成して、イメージを容易に復元できるようにします。イメージの索引の作成を参照してください。
オプション 1:Ctrl + I
オプション 2:[ファイル] > [IMXの作成] をクリックします。
[除外]
クライアント コンピュータにイメージファイルを配布する際に含めないボリューム、フォルダ、およびファイルのみに印をつけます。
注意: [詳細] ウィンドウのファイルの隣りにあるチェックボックスをクリックして、そのファイルを除外することもできます。. アイコンがチェックボックスを置き換えます。

オプション 1:Delete キー

Ç<Ç¾ÇÕ

オプション 2:[編集] > [除外] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:ファイルを右クリックして [ファイルの除外] を選択します。
[展開]
イメージ ファイルからボリューム、フォルダフォルダ (下位フォルダを含む) またはファイル全体を展開します。フォルダまたはファイルを保存する配布先ボリュームまたはディレクトリを選択することができます。フォルダの展開を参照してください。
注意: 大量のデータおよび多数のファイルを展開すると数分かかることがあります。

オプション 1:Ctrl + E

Ç<Ç¾ÇÕ

オプション 2:[編集] > [展開] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:項目を右クリックして [ファイルの展開] を選択します。
[検索]
特定の名前とワイルドカード文字を使ってイメージファイル内のファイルまたはフォルダを検索します。「?」を任意の1文字を表す変数として、または「* 」（アスタリスク）を任意の文字列を表す変数として使用できます。ファイルの検索:を参照してください。

オプション 1:Ctrl + F

Ç<Ç¾ÇÕ

オプション 2:[編集] > [検索] をクリックします。

オプション 3:コンテナ オブジェクトを右クリックして [検索] を選択します。
[含める]
クライアント コンピュータに配布するときに、以前 [除外] と印をつけたボリューム、フォルダ、およびファイルをイメージ ファイルに含めることができます。
注意: [詳細] ウィンドウのファイルの隣りにある [image] をクリックして、前に除外したファイルを含めることもできます。.チェックボックスが再度表示されます。

オプション 1:Insert キー

Ç<Ç¾ÇÕ

オプション 2:[編集] > [含める] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:除外した項目を右クリックして [含める] を選択します。
Exe の作成
自己解凍イメージ ファイルを既存のイメージ ファイルから作成します。Exe の作成を参照してください。
オプション 1:Ctrl + M
オプション 2:[ファイル] > [Exeの作成] をクリックします。
[ファイルを開く]
（複数ファイルに使用可能）
ImageExplorer が実行中のコンピュータ上に関連付けられたアプリケーションがある場合に、そのアプリケーションでファイルを開きます。

オプション 1:ダブルクリック

Ç<Ç¾ÇÕ

オプション 2:[編集] > [開く] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:ファイルを右クリックして、[開く] を選択します。
[アプリケーションから開く]
選択したプログラムを使ってファイルを開くことができます。そのファイルがすでにあるプログラムに関連付けられている場合、ダブルクリックして開けます。そのプログラムを変更またはデフォルトのクイック オープン機能を選択するために[アプリケーションから開く] を使用します。
注意: IBMaster 4.5 で作成されたイメージ ファイルを開くことはできません。ただし、イメージの変換機能を使用して、イメージ ファイルを現在の RapiDeploy ファイル フォーマットに変換することができます。
オプション 1:ダブルクリック (まだ関連付けられていない場合)

Ç<Ç¾ÇÕ

オプション 2:[編集] > [アプリケーションから開く] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:ファイルを右クリックして、[アプリケーションから開く] を選択します。
[イメージファイルを開く]
RDeploy.exe または IBMaster.exe で作成されたイメージ ファイルを開きます。IBMaster で作成したファイルは読み取り専用ですが、表示および展開することもできます。IBMaster.exe で作成したファイルを編集するには、以前のバージョンの ImageExplorer が必要です (Deployment Solution 5.5 以前、または RapiDeploy 4.5 以前のバージョン)。

オプション 1:Ctrl + O

Ç<Ç¾ÇÕ

オプション 2:[ファイル] > [開く] をクリックします。
[貼り付け]
あるロケーションから別のロケーションにファイルまたはフォルダを移動します。

オプション 1:Ctrl + V

Ç<Ç¾ÇÕ

オプション 2:[編集] > [貼り付け] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:項目を右クリックして [貼り付け]を選択します。
印刷
フォルダ:フォルダ構造を印刷します。サブフォルダとファイルの最終変更日時とサイズも印刷されます。

ファイル:実際のファイルを印刷します。ファイルを印刷するには関連付けられたアプリケーションがインストールされている必要があります (例えば、DOC ファイルを印刷するには MS Word が必要です)。
フォルダ内容の印刷およびファイルの印刷を参照してください。

オプション 1:Ctrl + P

Ç<Ç¾ÇÕ

オプション 2:[ファイル] > [印刷] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:項目を右クリックして [印刷] を選択します。
[プロパティ]
サイズ、最終変更日、属性などのフォルダやファイルの全般情報を提供します。イメージ、ボリューム、フォルダ、またはファイルに対して異なるプロパティが表示されます。プロパティの表示を参照してください。

オプション 1:Alt + Enter

Ç<Ç¾ÇÕ

オプション 2:[ファイル] > [プロパティ] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:項目を右クリックして [プロパティ]を選択します。
[ファイルの置換]
（複数ファイルで使用可能）
イメージ内のファイルを別のロケーションにあるファイルで更新する手段を提供します。双方が同じファイル名である必要があります。

オプション 1:Ctrl + L

Ç<Ç¾ÇÕ

オプション 2:[編集] > [置換] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:ファイルを右クリックして [ファイルの置換] を選択します。
[元に戻す]
（複数ファイルで使用可能）
[ファイルの置換] オプションに対するアンドゥ機能です。前に置換されたファイルを元のファイルに戻します。

オプション 1:Ctrl + R

Ç<Ç¾ÇÕ

オプション 2:[編集] > [元に戻す] をクリックします。

Ç<Ç¾ÇÕ

オプション 3:項目を右クリックして [ファイルを元に戻す] を選択します。
イメージの分割
あるサイズのイメージ ファイルを別のセグメント化されたサイズに分割します。イメージの変換を参照してください。
オプション 1:Ctrl + S
オプション 2:[ファイル] > [イメージの分割] をクリックします。


ImageExplorerの使用方法

ImageExplorer が実行されている状態で、プログラム メニューバーから [ファイル]>[開く] を選択し、表示または変更したいイメージファイルを開きます。

注意: 現在使用している RDeploy.exe ではなく IBMaster.exe で作成されたイメージファイルは、Deployment Solution 5.6 以降に同梱されているバージョンの ImageExplorer では変更ができません。しかし、IBMaster で作成されたファイルの表示と展開は可能です。フルアクセスのファイル属性の場合でも、ImageExplorer は、IBMaster で作成されたファイルを常に読み取り専用として表示します。以前のイメージファイルを変更するには、以前のバージョンの Deployment Solution に同梱されているバージョンの Altiris ImageExplorer を使用する必要があります。

関連項目: プロパティの表示, 新規ファイルの追加およびフォルダの展開。


プロパティの表示

ImageExplorer でイメージファイルを開いた後、イメージファイルとその要素に関する基本情報は、ファイルまたはボリューム（パーティション）名を選択して [プロパティ] をクリックすることにより表示することができます。イメージファイル、ボリューム、またはファイルのプロパティ ページは、右クリックして [プロパティ] を選択するか、メニューから [ファイル] > [プロパティ] をクリックするか、またはAlt + Enter キーを入力することによって開くことができます。プロパティ ページは、イメージ要素の種類に応じて適切なタブをを開きます。


イメージファイルの全般プロパティ

このページはイメージ ファイルのデータを表示します。保存したイメージの[プロパティ] を選択してから [全般] タブをクリックすると、イメージ項目とサイズ、ロケーション、属性などのプロパティデータが表示されます。

イメージ プロパティ ページには、イメージファイル名と関連するイメージデータがあります。例:[サイズ] フィールドでは、配布元コンピュータのハードディスク上でそのイメージが占めている空間を表示できます。[ディスク上のサイズ] フィールドでは、配布前の圧縮されたイメージファイルの実際のサイズが表示されます。

イメージファイルの[パスワード] をこのダイアログボックスで変更することも可能です。


ボリュームの全般プロパティ

このページはボリュームのデータを表示します。イメージ ファイル内の選択フォルダの[プロパティ] を選択してから[全般] タブをクリックすると、サイズ、ロケーション、属性などのプロパティ データが表示されます。


フォルダの全般プロパティ

このページはフォルダのデータを表示します。イメージ内の選択ファイルの [プロパティ] を選択してから [全般] タブをクリックすると、その中にあるファイルと、サイズ、ロケーション、属性などのプロパティデータが表示されます。


ファイルの全般プロパティ

このページはファイルのデータを表示します。イメージ ファイル内の選択フォルダの [プロパティ] を選択してから [全般] タブをクリックすると、その中にあるファイルと、サイズ、ロケーション、属性などのプロパティ データが表示されます。


イメージファイルの詳細プロパティ

このページは、イメージ ファイル内の構成ボリュームが表示されます。イメージ内のボリューム数および各ボリューム名を[ボリューム]ウィンドウにリスト表示します。イメージ ファイルがフルアクセスのファイル属性の場合は、イメージの詳細を変更することができます。


ディスク パーティションのプロパティ

その他プロパティ ページはイメージファイル内の各ボリュームのシステム属性の総合的なリストを提供します。ここには、パーティション テーブルからインポートされたデータを含むボリュームデータと統計があります。


ファイルを開く

イメージ内のファイルを開くには、ImageExplorer の [詳細] ウィンドウのファイルをダブルクリックするか、右クリックして [開く] を選択します。ファイルは関連付けられたアプリケーションで開きます。関連付けられたプログラムがない場合には、[アプリケーションから開く] ダイアログボックスが表示され、ユーザはそのファイルに関連付けるプログラムを選択することができます。

注意: そのファイルを右クリックして[アプリケーションから開く] コマンドを選択して、ファイルをプログラムに関連付けることもできます。

[クイックボタン-開く] 機能を使えば、プログラムを関連付けなくても、デフォルトのプログラムを選択 (Microsoft Notepad がデフォルト プログラム) することができます。[クイックボタン-開く] 機能のデフォルト プログラムは[表示] > [設定] をクリックして[アプリケーションから開く] ボックスを編集することで変更できます。

関連項目: ファイルの印刷および設定


分割イメージファイルを開く

イメージが大きすぎる場合やイメージを保存するサイズに制限がある（複数のCDに収められるようにイメージファイルを 600MB のサイズで分割するなどの）場合に、イメージファイルを複数ファイルに分割する RapiDeploy の機能が利用できます。編集の際 ImageExplorer は分割イメージファイルを追跡し、リンクされているイメージファイルが同じディレクトリ内に保存されていない場合に通知します。


不足している分割イメージファイルを検索する

分割イメージのうち複数のファイルが別のフォルダまたは別のCD上に保存されている場合、このダイアログ ボックスが開き、不足している分割イメージファイルを探すことができます。フィールドにパスを入力するか、不足ファイルを参照してください。ImageExplorer は、分割イメージの全ファイルを追跡しているので、同じフォルダ内に存在しない場合には、不足している分割イメージファイルについて通知します。


新規ファイルの追加

  1. [Altiris] [ImageExplorer] を開きます。
  2. [ファイル] > [開く] をクリックします。イメージ ファイルを選択します。
  3. [OK] をクリックします。
  4. イメージ内の追加したいボリュームまたはフォルダを右クリックして[ファイルの追加]を選択します。[追加するファイルの選択] ダイアログボックスが表示されます。

オプション 1:

    • ファイルを参照して[OK] をクリックします。これで、新規ファイルがイメージ内に表示されます。

      • オプション 2:

    • ファイルを Windows のエクスプローラから、ImageExplorer に表示されているイメージファイル内の選択フォルダまたはボリュームにドラッグするか、そのファイルをコピーして貼り付けます。オプションが選択されている場合（設定 ダイアログ ボックスの [貼り付け/ドロップ操作] を参照）、イメージ ファイルへのファイルコピーを確認するメッセージ ボックスが表示されます。

注意: [ImageExplorer] ダイアログ ボックスの [詳細] ウィンドウのファイルをダブルクリックして、テキスト ファイルにアクセスおよび編集できます。


イメージの変換

イメージの内部ファイル フォーマットは、Deployment Server バージョン 5.5 以前のファイル フォーマット 4 から、Deployment Server 5.6 以降ではファイル フォーマット 6 に変更されました。ファイル フォーマット 6 は、そのリリース以降同じままに維持されていますが、フォーマット全体の構造を改善するために小規模な変更を実施しています。

この機能を使用すると、以前作成されたイメージ ファイルを選択して、RapiDeploy で今日使用されている現在のファイル フォーマットに変換することができます。Deployment Server の将来リリースでファイル フォーマットが変更された場合、イメージ ファイルを変換すると、最新のファイル フォーマットに変換されます。

イメージ ファイルを変換するときの注意点:

  • 古いイメージにイメージ索引 (imx) ファイルがある場合は、新規イメージ索引ファイルが作成されます。
  • 古いイメージ ファイルが自己展開イメージの場合、埋め込まれた RapiDeploy コードが削除され、イメージは .img ファイルに復元されます。埋め込まれた自己展開コードが削除されたことを警告するメッセージは表示されません。
  • 古いイメージにパスワードが設定されている場合、作成される新規イメージ索引ファイルにはパスワードは設定されません。ただし、パスワードが削除されたことを示すメッセージが表示されます。
  • ImageExplorer は、古いイメージ ファイルを新規イメージ ファイルに変換する前に、イメージの各セグメントを読み取ります。このため、ファイルの変換にかかる時間は異なる可能性があります。多数のセグメントを含む大規模なファイルがある場合、このプロセスには長い時間がかかります。
フィールド定義

Image File to Convert:変換するイメージ ファイルを選択します。

Current segment size: デフォルトでは、RapiDeploy イメージのセグメント サイズは 2 GB です。

Current segment count:イメージ ファイルのセグメント数。

New Output Image File: 新規セグメント サイズに基づいて、変換するイメージ ファイルのフォルダとファイル名を選択します。

New segment size (MB): ドロップダウン リストからイメージ セグメントのサイズを選択します。CD、zip ドライブなどのデフォルト サイズを含むオプションの一覧。ファイル セグメントがこの限度に達すると、イメージ全体が変換されるまで新規セグメントが作成されます。

Estimated segment count: 変換するために選択したファイルの予測セグメント数。

イメージ ファイルを変換するには
  1. [ファイル] をクリックして、[イメージファイルの変換] を選択します。
  2. [参照] をクリックして、フォルダに移動し、変換するイメージ ファイルを選択します。
  3. [参照] をクリックしてフォルダに移動します。変換されたイメージの新しいファイル名を入力します。
  4. ドロップダウンの矢印をクリックし、一覧からセグメント サイズを選択します。
  5. [OK] をクリックします。


イメージの索引の作成

この機能を使用して、イメージ ファイルの索引ファイルを作成することができます。これにより、イメージを CD にコピーするとき、索引ファイルは、イメージの最初のセグメントと共に、イメージ ファイルの復元時に使用されるファイル情報を RapiDeploy に提供できます。

例:.img、.002、.003、および .004 など、複数のセグメントを含むイメージがある場合、ImageExplorer はセグメント .004 の最後にテーブルのコンテンツを作成して、イメージのセグメントごとにファイル情報を識別します。

この機能を使用して、.imx という名前の新規ファイルが作成されます。次に、セグメントを CD にコピーするときに、.img と .imx ファイルを同じ CD 上に配置するように選択できます。必要に応じて、他のセグメント .002、.003、および .004 を追加の CD にコピーできます。CD を使用してイメージを復元すると、イメージを復元するために必要な情報は .img および .imx ファイルを含む最初の CD から RapiDeploy に提供されます。これにより、最初の CD、最後の CD を挿入して次に RapiDeploy でイメージの復元するために最初の CD を挿入する必要がなくなるため、イメージの復元が容易になります。

また、RapiDeploy で [イメージ インデックス (.imx) ファイルの作成] オプションを選択して、イメージの作成時にイメージの索引を作成することもできます。『 RapiDeploy リファレンス マニュアル』を参照してください。

フィールド定義

索引を作成するイメージファイル: 索引を作成するイメージ ファイルを選択します。

Output Folder for Index (optional):索引出力のフォルダを作成しない場合、.imx ファイルは索引を作成するために選択したイメージと同じフォルダに作成されます。

索引イメージを作成するには
  1. [ファイル] をクリックして、[イメージファイルの変換] を選択します。
  2. [参照] をクリックして、フォルダに移動し、イメージ ファイルを選択します。
  3. [参照] をクリックして、索引ファイル出力のフォルダに移動します。
  4. [OK] をクリックします。


フォルダの展開

この機能を使用して、イメージからフォルダまたはファイルを取り出し、外部の配布先フォルダに保存することができます:

  1. Altiris ImageExplorer を開きます。
  2. [ファイル] > [開く] をクリックします。イメージ ファイルを選択します。
  3. [OK] をクリックします。
  4. イメージ内のフォルダを選択、右クリックしてから [フォルダの展開] を選択します。[参照] ダイアログ ボックスが表示されます。
  5. 展開したフォルダを保存する、ローカルディスク上またはネットワーク上のフォルダを選択します。
  6. [OK] をクリックします。

注意: 大量のデータおよび多数のファイルを展開すると数分かかることがあります。


ファイルの検索:

イメージファイル内のファイルまたはフォルダを検索するには、[検索対象] ボックスに、文字列または文字（英数字）を入力します。「 ? 」（疑問符）を任意の1文字を表す変数として、または「* 」（アスタリスク）を任意の文字列を表す変数として使用できます。

ファイルを検索するには、ツリー表示からイメージ ファイル、ボリューム名またはフォルダ名を選択して検索ドメインを設定します。検索ドメインを変更してから、[検索] をクリックすることができます。

フィールド定義

フォルダを含める: 検索結果に一致フォルダを含める場合にはこのオプションを選択します。

ファイルを含める: 検索結果に一致ファイルを含めるには、このオプションを選択します。

指定した検索条件に一致するファイルとフォルダは、[ファイル名] と [ロケーション] で整理されて結果ボックスに一覧表示されます。


結果のフィルタ

ファイルの検索: ダイアログボックスの [フィルタ] をクリックすると、関連付けられたシステム属性（読み取り専用、隠しファイル、システム）および ImageExplorer 属性 (追加済み、除外済み、置換済み) に基づいたファイルの高度な検索を行うことができます。

フィールド定義

検索対象: ファイルまたはフォルダのシステム属性または ImageExplorer 属性に従って、ファイルを検索する文字または文字列を入力します。 [一致するファイルを含める] をクリックしてファイルを選択します。[一致するフォルダを含める] をクリックしてフォルダを選択します。

注意: 指定ディレクトリ内を検索するには、ツリー表示ウィンドウで特定ディレクトリを選択して、[検索] ダイアログボックスを開きます。

下記の属性では、次の役割を持った 3 段切り替えのチェックボックスを使用しています:

  • 濃い実線のチェックマークは、項目がその属性を必ず含まなければならないことを示します。
  • チェックマークなしは、項目がその属性を含まないことを示します。
  • グレーの薄いチェックマークは、その値が NULL で項目が値を含んでも含まなくても良いことを示します。

属性: これは、イメージ作成時にオペレーティング システムが割り当てたファイルのシステム属性です。

フラグ: これは、ImageExplorer が割り当てた属性です。


Exe の作成

この機能を使用して、既存のイメージ ファイルの自己展開ファイルを作成します。これにより、クライアント コンピュータで実行可能ファイルを実行できます。この機能はネットワークを介したイメージングのために Deployment Server および RapiDeploy にアクセスできないコンピュータに対してイメージを復元する必要がある場合に役立ちます。

RapiDeploy を使って作成され、Deployment Server 5.6 以降で開始されるイメージを作成するために使用されたイメージ ファイルを選択できます。Altiris IBMaster 4.5 以前を使って作成されたイメージがある場合、この機能を使用することはできません。ただし、フォルダに移動してイメージを選択すると、すべての img ファイルが表示されます。イメージの変換機能を使用して、イメージを最新の RapiDeploy ファイル フォーマットに変換することができます。

自己展開ファイルは、有効なイメージ ファイルと RapiDeploy で構成され、実行可能ファイルに埋め込まれます。自己展開ファイルをフォルダまたはリムーバブル メディアにコピーし、コンピュータ上で手動で実行するか、Deployment Server で導入イベントを作成し、自己展開ファイルを複数のコンピュータに配布することができます。

Deployment Server を通じて RapiDeploy の新しいバージョンを使用できるようになったら、Exe の作成をもう一度実行して自己展開ファイルを再作成することができます。イメージ ファイルの埋め込まれた RapiDeploy コードは、RapiDeploy の最新バージョンに置き換えられます。

ImageExplorer は .img セグメントのみを読み取るので、この処理にかかる時間は異なります。ファイルが 2 GB の場合は、.img セグメントが 700 MB の場合よりも処理に時間がかかります。

RapiDeploy とイメージ ファイル (.img) の最初のセグメントのみを組み合わせて、イメージを復元する実行可能ファイルを作成します。ただし、索引 (.imx) など、イメージ全体を構成している他のすべてのセグメントはイメージを復元するときに必要です。

関連項目: イメージの索引の作成 を参照してください。

フィールド定義

Current self-extractor type: 選択したイメージ ファイルはこの種類のオペレーティング システムのイメージ ファイルです。

コピーの作成: ImageExplorer のチェックボックスをオンにして、オリジナル イメージ ファイルに影響を及ぼすことなく自己展開イメージ ファイルを作成します。

注意: このチェックボックスをオフにして、[Exeの作成] プロセスが失敗し、オリジナル イメージ ファイルが損傷または破損した場合、オリジナル イメージ ファイルを作成した自己展開ファイルの作成ができなくなります。

イメージ ファイル サイズ: 選択された現在のイメージのサイズ。

既存のコードの削除: このオプションを使って、自己展開イメージから .exe コードを削除します。イメージ ファイルは、.img ファイル拡張子を持つオリジナルの状態に戻ります。このオプションは、イメージ ファイルに自己展開コードがある場合のみ使用できます。そうでない場合、このオプションを使用することはできません。

DOS: このモードは RapiDeploy グラフィカル ユーザ インターフェースを使って、実行中のイメージ ファイルの進捗を表示します。

DOS テキストモード: テキスト バージョンのユーザ インターフェースです。進捗バーは、イメージ ファイルが実行されているときにクライアント コンピュータのディスプレイの下部に表示されます。

自己展開イメージ ファイルを作成するには
  1. [ファイル] をクリックし、[自己展開の作成] を選択します。
  2. [参照] をクリックして、イメージ ファイルのロケーションに移動します。
  3. オリジナル イメージ ファイルを自己展開イメージ ファイルにする場合は [コピーの作成] をオフにします。
  4. [自己展開タイプの変更] を選択します。フィールド定義を参照してください。
  5. [OK] をクリックします。自己展開ファイルは、オリジナル イメージ ファイルと同じディレクトリに作成されます。[不十分な空き容量] ダイアログが表示された場合は、不十分な空き容量を参照してください。


不十分な空き容量

十分な空き容量がないので、自己展開ファイルを作成するために選択したイメージ ファイルを作成できません。[不十分な空き容量] ダイアログでは、自己展開ファイルを作成する別のロケーションを選択できます。ディレクトリ パスを入力するか、[参照] ボタンをクリックして、より大きなディスク容量があるロケーションに移動します。[OK] をクリックします。


フォルダ内容の印刷

イメージファイル、ボリューム（パーティション）、またはフォルダ内のファイルおよびサブフォルダのリストが印刷できます。選択したオプションに従って、構成ファイルとサブフォルダを含み、各ファイルの最終変更日時、サイズ、その他の属性を持つフィールドを含むレポートを印刷することが可能です。

イメージファイル、ボリューム、またはフォルダの内容を印刷する時に[OK] をクリックして、レポートファイルの印刷プレビュー を表示します。

フィールド定義

タイトル： レポート ページの上に表示されるタイトルを入力します。

印刷内容

このフォルダのみ: 選択したイメージ、ボリューム、またはフォルダ内のファイルのみを印刷します。サブフォルダは印刷されません。

このフォルダとサブフォルダ: 選択したイメージ、ボリューム、またはフォルダ内のファイルとすべてのサブフォルダとファイルを印刷します。

除外項目の印刷:前に [除外] でマークされたファイルを印刷します。

< . > 項目の印刷:各フォルダ内にある< .>（拡張子）で指定される項目を印刷します。属性および日/時プロパティは、イメージファイル内のこの隠しフォルダに保存されます。

印刷フィールド

最終変更日時を含める: ファイルまたはフォルダが変更された日時を印刷します。

サイズを含める: ファイルのサイズを印刷します。

属性を含める: 読み取り専用、アーカイブ、隠しファイル、システムまたは圧縮 システム属性（読み取り専用、システム、隠しファイル）および ImageExplorer 属性（追加済み、除外済み、置換済み）を印刷します。

ファイル番号を含める: 各ファイルに関連付けられたファイル番号を印刷します。

関連項目: ファイルの印刷.


印刷プレビュー

イメージファイル、ボリューム、またはフォルダの印刷レポートのオンライン表示をします。ページ上部にレポート名が表示され、フォルダ内容の印刷 ダイアログボックスで選択された詳細が表に表示されます。

フィールド定義

保存: これをクリックして、レポートをテキスト ファイルに保存します。

行: レポート内の行数を表示します。

印刷: クリックするとレポートを作成します。


ファイルの印刷

ImageExplorer ダイアログボックスから関連付けられたプログラムを使用して実際のファイルを選択して印刷することができます。ファイルがプログラムに関連付けられていない場合、表示されるコンピュータにインストール済みプログラム リストから選択して、関連付けることが可能です。また[クイックボタン－印刷] でファイルを NotePad のような標準プログラムで開いてみることもできます。

フィールド定義

クイックボタン－印刷: このボタンをクリックすると、デフォルトのプログラムを実行し、選択したファイルを開き印刷します。デフォルトのプログラムは Microsoft Notepad です。ファイルを印刷するデフォルトのプログラムは、設定 ダイアログボックスにある [アプリケーションから印刷する] ボックスを使用して変更できます。

関連項目: フォルダ内容の印刷およびファイルを開く


イメージファイルにパスワードを設定する

イメージファイルを右クリックして[プロパティ]を選択します。 [属性]セクションで[パスワード]を選択してください。[パスワードの設定/変更] ダイアログボックスが表示されます。

フィールド定義

現在のパスワード: 現在のパスワードを入力します。

新規パスワード: 新規パスワードを入力します。

パスワードを確認してください: もう一度パスワードを入力して、正しく入力されていることを確認します。


設定

[表示] > [設定] をクリックして、Altiris ImageExplorer の基本設定を設定することができます。[クイックボタン－印刷]（ファイルの印刷を参照）または[クイックボタン－開く] （ファイルを開くを参照）オプション使用するときに、[設定] ダイアログボックスが開き、UI でメッセージボックスを使用する特定の操作を確認するオプションの設定、項目の表示または項目の除外オプションの設定、あるいはデフォルト プログラムの選択が行えます。

確認

読み取り専用操作で開く: ファイルを読み取り専用状態で開き、結果として変更の保存ができなくなる際に、ユーザに確認メッセージを提示します。例:RapiDeploy 4.5 以前のバージョンで作成されたイメージファイルを開いた時に、読み取り専用で開かれ実行された任意の操作は保存できません。したがって、このファイルを開く際には、ファイルが保存できないことをユーザに通知する確認メッセージが表示されます。

ファイルの上書き操作: イメージ ファイルからファイルを展開し展開先ドライブの既存ファイルを上書きするときに、ユーザに確認メッセージを提示します。

ファイルを元に戻す操作: ファイルの置換後にイメージ ファイルを元のファイル構造と内容に戻す[元に戻す]操作を実行するときに、確認メッセージを提示します。

貼り付けおよびドロップ操作: ファイルをイメージ フォルダ内の新規フォルダにドラッグする際、ファイルを別のフォルダに移動するコピーと貼り付け操作を行う際、または新規ファイルの追加 コマンドを使用する際に確認メッセージを表示します。

除外操作: [除外] オプションをファイルに割り当てる（選択ファイルをイメージの一部として配布しない）際に確認メッセージを表示します。このメッセージは、ファイルまたはフォルダのチェックボックスをクリックした場合、または [除外] 操作を選択した場合に表示されます。

フォルダの上書き操作: イメージ ファイルからフォルダを展開し展開先ドライブの既存フォルダを上書きするときに、ユーザに確認メッセージを提示します。

表示設定

ヘルプの表示: 選択すると ImageExplorer ユーザインタフェースの上部にヘルプを表示します。これで、ImageExplorer ユーザ インターフェースの後に表示するのではなく、ヘルプをプログラムに並べて表示することができます。

ファイル番号の表示: イメージに関連付けられているファイル番号を表示しますNTFS では、ファイル番号が自動的に与えられます。FAT、EXT2、EXT3、およびその他のファイルシステムでは、イメージファイルの作成時に RapiDeploy がファイル番号を与えます。

除外項目の表示: イメージで [除外済み] になっているファイルを表示します。画面の表示を更新したあとでファイルが表示されます。

除外項目の展開: 除外済みのファイルとフォルダをイメージファイルから展開先のフォルダに展開することを許可します。この設定により、[除外] コマンドの実行時に、事前に [除外済み] とマークされたすべてのファイルを外部の展開先フォルダに保存するように含めることができます。

追加項目に色付け: このオプションを選択すると、イメージに追加されたファイル/フォルダを青いテキストで示します。[ファイルの追加]および[フォルダの追加]を参照してください。

置換項目に色付け: このオプションを選択すると、イメージに置換されたファイル/フォルダをマジェンタで示します。[ファイルの置換] （複数ファイルで使用可能）を参照してください。

除外項目の色付け: このオプションを選択すると、イメージに追加されたファイル/フォルダを赤いテキストで示します。[除外]を参照してください。

[ファイルを開くおよび印刷するデフォルトのプログラム]

この設定は、[アプリケーションから開く] と [開く] 機能で表示される [クイックボタン－開く] と [クイックボタン－印刷] のデフォルト設定です。Microsoft Notepad などの一般的プログラムにファイルを関連付けるために使用します。

プログラムから開く: 選択ファイルを実行するためのデフォルトのプログラムを設定します。デフォルトのプログラムは Microsoft Notepad です。ファイルを開くを参照してください。

プログラムから印刷: 選択ファイルを印刷するデフォルトのプログラムを設定します。デフォルトのプログラムは Microsoft Notepad です。ファイルの検索:を参照してください。


イメージの分割

この機能を使用すると、選択したセグメント サイズに基づいてイメージ ファイルを新規イメージ ファイルに分割（リライト）することができます。イメージの変換機能を使って、イメージのファイル フォーマットを RapiDeploy で使用される現在のフォーマットに変換しているときは、オリジナル イメージのフォーマットを維持してイメージを分割しますが、セグメントのサイズは変更されます。

例:2 GB のイメージ ファイルがあり、CD に収まらないのでイメージを分割したい場合があります。この場合、新規セグメント サイズとして 650 MB または 700 MB を選択すると、複数のセグメントを持つ 1 つのイメージ ファイルが得られます。次に、セグメントを CD にコピーし、コピーした CD を使ってクライアント コンピュータでイメージ ファイルを復元することができます。

イメージ ファイルを分割するときの注意点:

  • 古いイメージが古いフォーマットのイメージ（IBMaster 4.5 以前）の場合、イメージを分割することはできませんが、変換することができます。この場合は、操作内容を確認するメッセージが表示されます。操作を続行する場合、[Convert and Image] のすべての原則が適用されます。
  • 古いイメージにイメージ索引 (imx) ファイルがある場合は、新規イメージ索引ファイルが作成されます。
  • 古いイメージ ファイルが自己展開イメージであり、埋め込まれた RapiDeploy コードが残っている場合、新規イメージには、イメージ ファイルが本来作成されたときと同じ RapiDeploy のバージョンが含まれます。ただし、イメージが古いフォーマットのイメージ（IBMaster 4.5 以前）の場合、イメージを分割することはできませんが、変換することができます。操作を続行すると、自己展開コードは削除されます。
  • 古いイメージにパスワードが設定されている場合、新規イメージ索引ファイルには同じパスワードが設定されます。ただし、古いイメージが古いフォーマットのイメージ（IBMaster 4.5 以前）の場合、イメージを分割することはできませんが、変換することができます。変換すると、パスワードは削除されます。
フィールド定義

Image File to Split: 分割するイメージ ファイルを選択します。

Current segment size: デフォルトでは、RapiDeploy イメージのセグメント サイズは 2 GB です。

Current segment count:イメージ ファイルのセグメント数。

New Output Image File: 分割するイメージ ファイルのフォルダとファイル名を選択します。

New segment size (MB): ドロップダウン リストからイメージ セグメントのサイズを選択します。CD、zip ドライブなどのデフォルト サイズを含むオプションの一覧。ファイル セグメントがこの限度に達すると、イメージ全体が分割されるまで新規セグメントが作成されます。

Estimated segment count: 分割するために選択したファイルの新規セグメント数に基づく予測セグメント数。

イメージ ファイルを分割するには
  1. [ファイル] をクリックして、[イメージファイルの変換] を選択します。
  2. [参照] をクリックしてフォルダに移動し、分割するイメージ ファイルを選択します。
  3. [参照] をクリックしてフォルダに移動し、イメージの新規ファイル名を入力します。
  4. ドロップダウンの矢印をクリックし、一覧からセグメント サイズを選択します。
  5. [OK] をクリックします。


コマンド ライン スイッチ

この機能を使用すると、コマンド ラインからのイメージ管理を容易にする Deployment Server Run Scripts やバッチ ジョブを作成できます。一部のスイッチの最後には、追加のコマンドを許可することを示す選択オプションを一覧で表示します。

オンライン コマンド ライン オプションにアクセスするには
  1. Windows 環境から [スタート] > [ファイル名を指定して実行] をクリックします。
  2. [名前] フィールドに「CMD」と入力します。
  3. 「C:\Program Files\Altiris\eXpress\Deployment Server\」（デフォルトのインストール パス）と入力します。
  4. 「imgexpl /?」と入力して、コマンド ライン スイッチ ページを表示します。
    コマンド ライン
    説明
    パラメータ
    開くまたは操作するイメージ ファイル（w2k.img, xp.img などのように繰り返しが可能）
    スイッチ
    -register: Windows レジストリにファイル タイプを登録します。
    -unregister: Windows レジストリのファイル タイプを登録解除します。
    -add <src> <dst>:ファイル、フォルダ、またはボリュームをイメージに追加します。<-overwrite> オプションを受け入れます。
    ソース（src）を入力時にワイルドカードを使用できます。
    -extract <scr> <dst>:ファイル、フォルダ、またはボリュームをイメージから展開します。<-overwrite> オプションと <-size> オプションを受け入れます。
    -convert <dst>:古いフォーマットのイメージを RapiDeploy で使用されている現在のイメージ フォーマットに変換します。<-overwrite> オプションと <-size> オプションを受け入れます。
    -split <dst>:イメージを新規サイズのファイル セグメントに分割します。<-overwrite> オプションと <-size> オプションを受け入れます。
    オプション
    -lang <lang code>:*ユーザ インターフェースの言語コードを指定します。
    -silent:*確認またはエラーを表示しません。
    -password <pwd>:*開いているイメージ ファイルのパスワード。
    -overwrite: サイレント モードのときに操作を確認しません。
    -size <size in MB>:新規イメージ セグメントのサイズ（MB単位）。
    * コマンドで使用できるオプションを示します。
    プロセス終了コード
    0 成功
    2 コマンド ライン構文エラー
    4 ファイル タイプの登録または登録解除のエラー
    6 ユーザによる操作の解除
    8 読み取り専用イメージへの書き込みの試行
    10 パスワードの無効
    12 操作実行中のエラー
    14 イメージ ファイルが見つからないか、イメージを開こうとしてエラーが発生
    16 ソースが見つからないか、ソースを開こうとしてエラーが発生
    18 移行先が見つからないか、移行先を開こうとしてエラーが発生

例

  1. パスワード「develop」を必要とする W2k.img を開きます。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop
  2. 「password」と「sales」という異なるパスワードを持つ 2 つのイメージ ファイルを開きます。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop f:\w2k.img -password sales
  3. e:\ にあるすべての*.txt ファイルを w2k.img のスロット 1 のボリュームの「temp」フォルダに追加します。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop -add e:\*.txt 1:\temp
  4. kernal.dll を w2k.img にあるボリューム「sys」の「Windows」フォルダから e:\dump に展開します。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop -add e:\*.txt 1:\temp
  5. 古いフォーマットのイメージ ファイル w2k.img を新規イメージ new2k.img に 650 MB セグメント単位で変換します。.
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -convert f:\new2k.img -size 650