Altiris IMAGEEXPLORER 6.8 帮助

Altiris
IMAGEEXPLORER 6.8
帮助


通知

ImageExplorer
2006 Altiris, Inc. 保留所有权利。
文档日期： 1 31, 2007
Bootworks 美国专利号 5,764,593。
RapiDeploy 美国专利号 6,144,992。
Recovery Solution 美国专利号 5,778,395、5,907,672、4701745、5016009、5146221、5144425、5463390、5506580、5532694、GB 2172127、B 904359、3606869。
其他未决专利
由于计算机软件本身固有的复杂特性，Altiris 公司将不作以下担保：Altiris 软件不会出现任何错误；软件可顺畅运行；软件与所有设备和软件配置相兼容；软件符合您的需求。
本文档内容仅用作参考信息，若有变更，恕不另行通知，并且不应将本文档内容解释为 Altiris 公司所作的承诺。 对于本文档中出现的错误和不准确的情况，Altiris, Inc. 概不承担责任。 要得到最新文档，请访问网站: www.altiris.com。
Altiris、Altiris 徽标、BootWorks、Eality、ImageBlaster、Inventory Solution、PC Transplant、RapiDeploy、RapidInstall 和 Vision 为 Altiris, Inc. 在美国的注册商标。 Altiris、Altiris 徽标和 ManageFusion 是 Altiris, Inc. 在其他国家或地区的注册商标。
Altiris Connector、Altiris eXpress、Altiris Protect、Application Management Solution、Application Metering Solution、Asset Control Solution、Asset Management Suite、Carbon Copy、Client Management Suite、Compliance Toolkit、Connector Solution、Contract Management Solution、Deployment Server、Deployment Solution、Energy Saver Toolkit、Education Management Suite、FSLogic、Handheld Management Suite、Helpdesk Solution、Lab Management Suite、ManageFusion、Migration Toolkit、Mobile Client for SMS、Monitor Solution、Network Discovery、Notification Server、Package Importer、Patch Management Solution、Problem Management Suite、Recovery Solution、Security Solution、Server Management Suite、Site Monitor Solution、Software Delivery Solution、SNMP Management、Software Delivery Suite、TCO Management Solution、UNIX Client for SMS, Web Administrator、Web Reports 和其他产品名称是 Altiris, Inc. 在美国和其他国家/地区的商标。
AuditExpress、Scan on Detect 和 SecurityExpressions 是 Pedestal Software Inc. 在美国的商标。 Audit on Connect 和 Audit on Detect 是 Pedestal Software inc. 在美国和其他国家/地区的商标。
WebLens 和 Guaranteeing Your Net Works 是 Tonic Software Inc. 在美国的注册商标。
WebInsight 和 RUM 是 Tonic Software Inc. 在美国的商标。
Microsoft、Windows 和 Windows 徽标是 Microsoft Corporation 在美国和/或其他国家/地区的商标或注册商标。
HP 和 Compaq 是 Hewlett-Packard Corporation 的注册商标。
Dell 是 Dell Inc. 的注册商标。
Macintosh 是 Apple Computer Corporation 的注册商标。
Palm OS 是 Palm Computing, Inc. 的注册商标。
BlackBerry 是 Research In Motion Limited Corporation 的服务标志和商标。
RIM 是 Research In Motion (RIM) 的服务标志和商标。
其他公司名称，品牌，或产品名称都是或可能是他们各自所属公司的商标。


Altiris ImageExplorer

Altiris ImageExplorer 提供查看和编辑映像文件的功能。 映像文件由 RapiDeploy 实用工具创建而成，RapiDeploy 是 Deployment Solution 中创建和分发磁盘映像文件（包含源计算机磁盘副本的 IMG 或 EXE 文件）时最常用的一个工具。

在分发映像文件并将其内容还原到客户计算机上之前，您可以使用 ImageExplorer 对映像文件进行修改（例如添加或删除数据文件、文件夹和应用程序）。 可以查看属性，执行操作，例如提取文件并将其保存到其他目标卷，或者在将映像文件分发到客户机上时排除不需要还原的文件。 也可以使用关联的应用程序打印文件夹内容或编辑文件。

另请参阅： 使用 ImageExplorer

ImageExplorer 的功能
  • 添加新文件和文件夹
  • 命令行模式
  • 转换映像
  • 创建映像索引
  • 提取文件和文件夹
  • 排除不需要还原的（或包括需要恢复的）卷、文件夹和文件夹
  • 在映像中查找文件
  • 使用相关联的程序打开文件并进行编辑
  • 生成自解压映像
  • 打印文件、文件夹和卷的树形映像结构
  • 替换文件
  • 恢复为原始的映像文件内容
  • 拆分映像
  • 查看、添加或更改映像说明
  • 查看映像中文件、文件夹和卷的属性
ImageExplorer 用户界面

单击工具栏上的 ImageExplorer 图标或单击工具 > ImageExplorer。 将打开 Deployment Share 中的 ImgExpl.exe 程序。
可以打开和编辑原始 IMG 文件类型的映像文件或包含 rdeploy.exe 运行版的 EXE 文件类型的映像文件。

Altiris ImageExplorer 提供以下功能，用于查看、管理和修改映像文件的卷、文件夹和文件元素。

功能 | 说明 | 按钮 | 访问
添加文件 | 将新文件添加到映像文件。 请参阅 添加新文件。 在树形视图中右键单击卷、文件夹或文件，可以访问添加文件菜单。 右键单击文件并选择添加文件后，将在同一文件夹下添加新文件。 |  | 方法一： Ctrl-A 方法二： 单击 编辑 > 添加文件 方法三： 右键单击一个项目再选择 添加文件
添加文件夹 | 将新文件夹添加到映像文件。 单击任意项将文件夹添加到容器对象。 在树形视图中右键单击卷、文件夹或文件，可以访问添加文件夹菜单。 |  | 方法一： Ctrl-D 方法二： 单击 编辑 > 添加文件夹 方法三： 右键单击一个项目再选择 添加文件夹
转换映像 | 将映像文件从文件格式 4 转换为 RapiDeploy 当前最常用的格式。 请参阅 转换映像。 |  | 方法一： Ctrl-T 方法二： 单击 文件 > 转换映像
复制 | 将文件或文件夹从一个位置复制粘贴到目标映像文件中。 注意: 在映像之间复制大量数据和大量文件可能需要几分钟。 |  | 方法一： Ctrl-C ªÚ'ﬂ 方法二： 单击 编辑 > 复制 ªÚ'ﬂ 方法三： 单击一个项目再选择 复制
创建映像索引 | 创建映像索引，以便于恢复映像。 请参阅 创建映像索引。 |  | 方法一： Ctrl-I 方法二： 单击 文件 > 创建映像索引
排除 | 将卷、文件夹和文件标记为排除，使其不包括在向客户机部署的映像文件内容中。 注意: 您也可以在 细节 框中电击文件旁边的复选框来排除一个文件。 图标将替换该复选框。 |  | 方法一： Del 键 ªÚ'ﬂ 方法二： 单击 编辑 > 排除 ªÚ'ﬂ 方法三： 右键单击一个文件再选择 排除文件
提取 | 从映像文件中提取完整的卷、文件夹（及其子文件夹）或文件。 允许您选择用以保存文件夹或文件的目标卷或目录。 请参阅 提取文件夹。 注意: 提取大量数据和大量文件可能需要几分钟。 |  | 方法一： Ctrl-E ªÚ'ﬂ 方法二： 单击 编辑 > 提取 ªÚ'ﬂ 方法三： 单击一个项目再选择 提取文件
查找 | 使用指定的名称或通配符在映像文件内部搜索文件或文件夹。 可以使用 ? 代表单个字符或使用 *（星号）代表多个字符。 请参阅 查找文件。 |  | 方法一： Ctrl-F ªÚ'ﬂ 方法二： 单击 编辑 > 查找 方法三： 单击一个容器目标再选择 查找
包括 | 在向客户机部署映像文件时，允许将先前标记为已排除的卷、文件夹和文件重新包括在部署内容中。 注意:您可通过单击在细节框中文件旁边的 [image] 来包含先前被排除的文件。 将会重新显示标记复选框。 |  | 方法一： Insert 键 ªÚ'ﬂ 方法二： 单击 编辑 > 包含 ªÚ'ﬂ 方法三： 右键单击一个排除项再选择 包含
生成自解压映像 | 从现有映像文件创建自解压文件。 请参阅 生成自解压映像。 |  | 方法一： Ctrl-M 方法二： 单击 文件 >生成自解压映像
打开文件 （仅用于文件） | 如果运行 ImageExplorer 的计算机上存在与文件相关联的应用程序，则使用该应用程序打开文件。 |  | 方法一： 双击 ªÚ'ﬂ 方法二： 单击 编辑 > 打开 ªÚ'ﬂ 方法三： 右键单击文件再选择 打开
打开方式 | 允许使用选择的程序来打开文件。 如果文件已与某个程序相关联，则只需双击即可打开该文件。 使用打开方式可更改程序或选择默认的"快速打开"功能。 注意: 由 IBMaster 4.5 创建的映像将不打开。 但是，可以使用转换映像功能将映像文件转换为当前的 RapiDeploy 文件格式。 |  | 方法一： 双击 (如果不关联) ªÚ'ﬂ 方法二： 单击编辑> 打开 ªÚ'ﬂ 方法三： 右键单击该文件再选择 打开
打开映像文件 | 打开使用 RDeploy.exe 或 IBMaster.exe 创建的文件。尽管使用 IBMaster.exe 创建的文件属性为只读，但可以查看和提取其中的文件。 您需要使用旧版本的 ImageExplorer（Deployment Solution 5.5 或更早版本，或 RapiDeploy 4.5 或更早版本）来编辑使用 IBMaster.exe 创建的文件。 |  | 方法一： Ctrl-O ªÚ'ﬂ 方法二： 单击文件 > 打开。
粘贴 | 将文件或文件夹从一个位置移到另一个位置。 |  | 方法一： Ctrl-V ªÚ'ﬂ 方法二： 单击 编辑 > 粘贴 ªÚ'ﬂ 方法三： 右键单击一个项目再选择 粘贴
打印 | 文件夹: 打印文件夹结构。 包括子文件夹和文件及其修改日期、时间和大小。 文件: 打印实际文件。 您必须已经安装了关联的应用程序来打印该文件 (例如: MS Word 以打印 DOC 文件)。 请参阅打印文件夹目录和打印文件。 |  | 方法一： Ctrl-P ªÚ'ﬂ 方法二： 单击 文件 > 打印 ªÚ'ﬂ 方法三： 右键单击一个项目再选择 打印
属性 | 提供有关文件夹或文件的一般信息，如大小、修改日期和系统属性。 映像、卷、文件夹或文件所显示的属性内容有所不同。 请参阅查看属性。 |  | 方法一： Alt-Enter ªÚ'ﬂ 方法二： 单击 文件 > 属性 ªÚ'ﬂ 方法三： 右键单击一个项目再选择 属性
替换文件 （仅用于文件） | 可使用其他来源的文件更新映像中包含的文件。 这两个文件必须同名。 |  | 方法一： Ctrl-L ªÚ'ﬂ 方法二： 单击 编辑 > 替换 ªÚ'ﬂ 方法三： 单击一个文件再选择 替换文件
恢复 （仅用于文件） | 对替换文件选项的撤消功能。 可以将已更改的文件恢复为原始文件。 |  | 方法一： Ctrl-R ªÚ'ﬂ 方法二： 单击 编辑 > 还原 ªÚ'ﬂ 方法三： 右键单击一个项目再选择 还原文件
拆分映像 | 将映像文件拆分为若干部分。 请参阅 转换映像。 |  | 方法一： Ctrl-S 方法二： 单击 文件 > 分割映像


使用 ImageExplorer

运行 ImageExplorer 时，可以从程序菜单栏中选择 文件 > 打开来打开您要查看或修改的映像文件。

注意: 由 IBMaster.exe 而不是有当前的 RDeploy.exe 创建的老的映像文件不能被与 Deployment Solution 5.6 或更高版本一起出版的 ImageExplorer 版本来修改。 但是，可以查看使用 IBMaster 创建的映像文件并且可以从中提取文件。 ImageExplorer 总是将使用 IBMaster 创建的文件显示为只读文件，即使该文件的属性为读写时也是如此。 要修改旧版本的映像文件，您需要使用更早版本的 Deployment Solution 中附带的 Altiris ImageExplorer。

另请参阅： 查看属性，添加新文件，和 提取文件夹。


查看属性

在使用 ImageExplorer 打开映像文件之后，可通过选择文件或卷（分区）名并单击属性来查看有关该映像文件及其映像内容的基本信息。 通过右键单击并选择属性、单击文件 > 属性或按 Alt-Enter 键，可以打开映像文件、卷或文件的属性页。 根据映像内容的不同类型，会打开相应的属性页选项卡：


映像文件的常规属性

此页显示映像文件的数据。 对所选映像选择属性打开其属性页后，单击常规选项卡可以查看映像中的内容项和属性数据（如大小、位置和系统属性）。

映像属性页包括映像文件的名称及其关联的映像数据。 例如： 大小字段显示映像文件在源计算机的硬盘上占用的空间大小。 磁盘占用量字段显示在部署压缩映像文件之前该映像的实际大小。

在该对话框中，可以修改映像文件的密码。


卷的 "常规" 属性

此页显示卷的相关数据。 对映像文件中所选文件夹选择属性后，单击常规选项卡可以查其属性数据（如大小、位置和系统属性）。


文件夹的 "常规" 属性

此页显示文件夹的相关数据。 对映像中的所选文件选择属性后，单击常规选项卡可以查看其包括的文件及其属性数据（如大小、位置和系统属性）。


文件的 "常规" 属性

此页显示文件的相关数据。 对映像中所选文件夹选择属性后，单击常规选项卡可以查看其包括的文件及相应属性数据（如大小、位置和系统属性）。


映像的说明属性

此页显示组成映像文件的卷。 该页显示了映像文件中的卷数，并在卷窗格中列出了每个卷的名称。 如果映像文件具有读写权限，则可以修改映像说明。


磁盘分区属性

"其他"属性页提供映像文件中每个卷的系统属性完整列表。 包括卷的数据和统计信息（其中包括从分区表中导入的数据）。


打开文件

要打开映像中的文件，可在 ImageExplorer 的详情窗格中双击该文件或右键单击并选择打开。 系统将使用与之相关联的程序打开该文件。 若无关联程序，则将显示打开方式对话框，允许用户为该文件选择和关联程序。

注意: 您也可以通过单击一个文件再选择 打开 命令来将一个文件与一个程序关联。

快速打开功能允许您选择默认的程序打开没有关联程序的文件（Microsoft 记事本是默认的程序）。 用户可以更改"快速打开"功能的默认程序，方法是单击查看 > 设置，然后在显示的打开程序对话框中进行相应的设置。

另请参阅： 打印文件和设置。


打开拆分映像文件

如果映像太大，或者您在存储映像时需要满足存储大小限制（例如将映像文件拆分成 600 MB 大小以便使用多张 CD 存放），则可以使用 RapiDeploy 中的"拆分映像"功能将映像文件拆分为多个文件。 编辑时，ImageExplorer 会跟踪这些拆分映像文件，如果某些链接映像文件存储在其他目录下，则还会提示您定位这些映像文件。


查找缺少的拆分映像文件

如果经拆分映像所生成的多个文件位于不同的文件夹或不同的 CD 中，则会显示此对话框，帮助您定位缺少的拆分映像文件。 在该字段中输入路径或浏览至所缺少的文件的位置。 ImageExplore 会跟踪拆分映像中的所有文件，如果这些文件不处在同一文件夹下，则会提示您定位缺少的拆分映像文件。


添加新文件

  1. 打开 Altiris ImageExplorer。
  2. 单击文件 > 打开。 选择映像文件。
  3. 单击确定。
  4. 右键单击映像中的首选卷或文件夹并选择添加文件。 将显示选择要添加的文件对话框。

方法一：

    • 定位 文件并单击确定。 在该映像中将会显示新文件。

      • 方法二：

    • 从"资源管理器"中将文件拖放到 ImageExplorer 显示的映像文件中的选定文件夹或卷下，或复制并粘贴该文件。 若选中此选项（请参阅设置对话框中的粘贴/拖放操作），则将显示一则消息，要求您确认将文件复制到映像文件的操作。

注意: 您可以通过双击在 ImageExplorer 对话框中的细节 框中的文件来访问和编辑文件。


转换映像

映像的内部文件格式已从 Deployment Server 5.5 版及更早版本中的文件格式 4 改成 Deployment Server 5.6 或更新版本中的文件格式 6。 文件格式 6 保留了其发布以来的主要特性，但仍进行了一些细微的更改，使总体格式结构得以改进。

此功能允许您选择先前创建的任何映像文件并将其转换成 RapiDeploy 目前使用的最新文件格式。 如果将来发布的 Deployment Server 改变了文件格式，则通过转换映像文件，总可以获得新文件格式的映像文件。

转换映像文件时，应注意以下几点：

  • 如果旧映像具有映像索引 (.imx) 文件，则会创建新的映像索引文件。
  • 如果旧映像文件是自解压映像，则会删除内嵌的 RapiDeploy 代码，映像将被恢复为 .img 文件。 删除内嵌的自解压代码时，不会发送警告消息。
  • 如果旧映像带有密码，所创建的新映像文件将不 使用此密码。 但是，用户会收到一则消息，提示密码已被删除。
  • ImageExplorer 在将映像转换为新映像文件之前需要读取该映像中的每个区段，因此对于包含不同区段数量的文件，所需的转换时间会有所不同。 如果您的映像文件包括许多区段，则该过程需要花费较长的时间。
字段定义

要转换的映像文件: 选择一个要转换的文件。

当前区段大小: 按默认，RapiDeploy 映像的区段大小是 2 GB。

当前区段计数: 在映像文件中的区段数。

新输出映像文件: 根据该新的区段大小，选择一个要转换的文件夹和文件名。

新区段大小 (MB): 从下拉列表中为映像区段选择一个大小。 此选项列表包括 CD、zip 驱动器等介质的默认大小。 当文件区段达到此限制时，就会创建新的区段，直至整个映像均转换完毕。

估计的区段计数: 在选择要转换的文件中的估计区段数。

要转换映像文件
  1. 单击文件并选择转换映像文件。
  2. 单击浏览定位文件夹，选择要转换的映像文件。
  3. 单击浏览定位文件夹。 为要转换的映像输入新的文件名。
  4. 单击下拉列表箭头，从列表中选择区段大小。
  5. 单击确定。


创建映像索引

此功能允许您为映像文件创建索引文件，这样，如果您将映像复制到 CD，则在从 CD 还原映像文件时，索引文件以及映像的第一个区段会为 RapiDeploy 提供文件信息。

例如： 如果您的映像包括多个区段，如 .img、.002、.003 和 .004，ImageExplorer 会在区段 .004的末尾创建目录，为该映像的每个区段标识文件信息。

利用此功能，创建名为 .imx 的新索引文件。 接着，在将区段复制到 CD 时，可以选择将 .img 和 .imx 同时复制到同一 CD 上。 其他区段 .002、.003 和 .004 可根据需要复制到其他 CD 上。 当您使用 CD 还原映像时，第一张 CD（包含 .img 和 .imx 文件）将为 RapiDeploy 提供还原映像所需的信息。 这使映像还原变得更容易，因为您不需要仅仅为了让 RapiDeploy 还原映像而在依次插入所有 CD 后再重新插入第一张 CD。

也可以在创建映像时建立映像索引，方法是在 RapiDeploy 中选中制作映像索引 (.imx) 文件选项。 请参阅《RapiDeploy 参考指南》。

字段定义

要索引的映像文件: 选择要索引的映像文件。

索引的输出文件夹 (可选的): 如果不为索引输出选择一个文件夹，.imx 文件将被创建在与要索引的选择的映像相同的文件夹中。

要创建索引映像
  1. 单击文件并选择创建映像索引。
  2. 单击浏览定位文件夹，选择一个映像文件。
  3. 单击浏览定位用于输出索引文件的文件夹。
  4. 单击确定。


提取文件夹

使用此功能，从映像中提取文件夹或文件并将其保存到外部目标文件夹中：

  1. 打开 Altiris ImageExplorer。
  2. 单击文件 > 打开。 选择映像文件。
  3. 单击确定。
  4. 在映像中选择一个文件夹，右键单击该文件夹并选择提取文件夹。 将显示"浏览"对话框。
  5. 在本地磁盘或网络上选择一个文件夹存放提取的文件夹。
  6. 单击确定。

注意: 提取大量数据和大量文件可能需要几分钟。


查找文件

要搜索映像文件中的文件或文件夹，可在查找内容框中输入字符串或字符（字母和数字）。 可以使用 ? （问号）代表单个字符或使用 * （星号）代表多个字符。

要搜索文件，可在树形视图中选择映像文件、卷名或文件夹名来设置搜索范围。 单击查找之前可以更改搜索范围。

字段定义

包含文件夹: 选择此选项来包含在搜索结果中的符合文件夹。

包含文件: 选择此项来包含在搜索结果中的符合文件。

满足指定搜索条件的文件和文件夹将会按照文件名和位置列在结果框中。


过滤结果

在查找文件对话框上单击过滤，可以打开文件的高级搜索选项，根据相关联的系统属性（只读、隐藏、系统）和 ImageExplorer 属性（新增、排除、替换）来搜索文件。

字段定义

寻找内容: 输入字符串或字符，根据系统特性或该文件或文件夹的 ImageExplorer 特性来寻找一个文件。 单击 包括 匹配的 文件，以便选择文件。 单击包括匹配的文件夹，以便选择文件夹。

注意:要搜索一个特定的目录，在树型视窗框中选择该目录，然后打开 "寻找" 对话框。

这些属性使用三态复选框，其含义如下：

  • 实线复选标记表示内容项必须包含该属性。
  • 空复选框表示内容项不能包含该属性。
  • 灰色复选标记表示该值为 Null，内容项可以包含此值，也可以不包含。

属性:这些是映像创建时有操作系统分派的文件的系统特性。

标志: 这些是由 ImageExplorer 分派的特性。


生成自解压映像

此选项允许您为现有的映像文件创建自解压文件，这样，您可以在客户机上运行这一可执行文件。 当需要在不能访问 Deployment Server 和 RapiDeploy（用于通过网络执行映像）的计算机上还原映像时，可以使用此选项。

可以选择使用 RapiDeploy 创建的映像文件，从 Deployment Server 5.6（或更高版本）开始，使用 RapiDeploy 来创建映像。 如果您的映像采用 Altiris IBMaster 4.5（或更早版本）创建而成，则无法使用此功能。 但是，您可以定位到文件夹，选择某个映像，显示其中的所有 .img 文件。 您可以使用转换映像功能将映像转换为最新的 RapiDeploy 文件格式。

此自解压文件由有效的映像文件和 RapiDeploy 组成，RapiDeploy 内嵌在可执行文件中。 您可以将自解压文件复制到文件夹或可移动介质中，并在任何计算机上手动运行该文件，也可以在 Deployment Server 上创建一项部署作业，并将自解压文件分发到多台计算机上。

若通过升级 Deployment Server 更新了 RapiDeploy 的版本，则可以通过重新运行 "生成自解压映像" 来重新制作任何自解压文件。 该映像文件内嵌的 RapiDeploy 代码将被最新版本的 RapiDeploy 代替。

ImageExplorer 仅读取 .img 区段，因此这一过程所需的时间将会随区段的大小而变化。 如果您的文件是 2 GB，则所需花费的时间将比 700 MB 的 .img 区段多。

RapiDeploy 和映像文件的第一区段 (.img) 合在一起，用于创建还原映像的可执行文件。 但是，在还原映像时，组成整个映像的所有其他区段（包括索引 .imx 文件）也是必需的。

另请参阅：请参阅创建映像索引。

字段定义

当前自解压映像类型: 选择的映像文件是该操作系统类型的。

保持原来的映像文件: 为 ImageExplorer 选择该复选框来做一个生成自解压映像文件而不影响原来的映像文件。

注意: 若清除此复选框，则若生成自解压映像 过程一旦失败，原始的映像文件也将随之遭到破坏或损坏，您将再也无法使用原始的映像文件创建自解压文件。

映像文件大小: 选择的当前映像文件的大小:

移除现存的自解压映像生成器: 使用次选项来从自解压映像移除 .exe 代码。 映像文件将回到其原始状态（文件扩展名为 .img）。 此选项仅适用于该映像文件包含自解压代码的情况，否则，此选项将不可用。

DOS: 本模式使用 RapiDeploy 图像用户界面来显示在它运行时映像文件的进度。

DOS 文本模式:这是文本版本用户界面。 在运行映像文件时，您可以查看客户机屏幕底部的进度栏。

要创建自解压映像文件
  1. 单击文件，并选择生成自解压映像。.
  2. 单击浏览定位映像文件的位置。
  3. 若希望将原始映像文件制作为自解压映像文件，则清除保留原始映像文件复选框。
  4. 选择更改自解压程序类型。 请参阅 字段定义。
  5. 单击确定。 创建的自解压文件将存放在原始映像文件所在目录。 若显示可用空间不足对话框，请参阅可用空间不足。


可用空间不足

由于可用磁盘空间不足，无法创建您选择用来生成自解压文件的映像文件。 可用空间不足对话框允许您选择创建自解压文件时所使用的备用位置。 输入目录路径或单击浏览按钮以定位具有更多磁盘空间的位置。 单击确定。


打印文件夹目录

可以以列表形式打印映像文件、卷（分区）或文件夹内部的文件和子文件夹。 根据所选的选项，您可以打印包含组成文件和子文件夹的报表以及包含每个文件的修改日期、时间、大小和其他属性等字段的报表。

打印映像文件、卷、文件夹的目录时，可单击确定查看报表文件的打印预览。

字段定义

标题:为报表页的顶部输入一个标题。

打印对象

仅该文件夹: 仅打印选择的映像，卷，或文件夹中的文件。 不会打印子文件夹。

该文件夹和子树: 打印在映像，卷或文件夹中的文件和所有子文件夹和文件。

打印排除的项目: 打印先前标记为排除的文件。

打印 < . > 项: 打印在每个文件夹中标识为 < 的项。 >（点号）的条目。 对于映像文件中的隐藏文件夹，将保存其系统属性和日期/时间属性。

要打印的字段

包含修改的日期和时间: 打印修改过的文件或文件夹的日期和时间。

包含大小: 打印文件的大小。

包含特性: 打印 只读，保存，隐藏，系统，或压缩的系统特性 (只读，隐藏) 和 ImageExplorer 特性 (添加，排除，替换)。

包含文件数目:打印与每个文件关联的文件数目。

另请参阅： 打印文件.


打印预览

查看针对映像文件、卷或文件夹的打印报表的联机显示。 报表的名称出现在页面的顶部，打印文件夹目录对话框中选择的详细信息则列在表格中。

字段定义

保存：单击以将报表保存到一个文本文件。

行: 查看报表中的行数。

打印：单击以打印该报表。


打印文件

从 ImageExplorer 对话框中，可以使用相关联的程序选择和打印实际文件。 如果您的文件未与程序关联，则可以从计算机上已安装程序的列表中选择一个进行关联。 也可以尝试快速打印，使用标准程序（例如记事本）打开文件。

字段定义

快速打印: 单击该按钮以运行默认程序来打开和打印选择的文件。 默认的程序是 Microsoft 记事本。 可以使用设置对话框中的打印程序框来更改打印文件的默认程序。

另请参阅： 打印文件夹目录和打开文件。


对映像文件设置密码

右键单击映像文件，然后选择属性。 在属性部分，选择密码。 将显示设置/更改密码对话框。

字段定义

当前密码: 输入当前密码:

新密码：输入新密码。

确认密码:再次输入密码以确认打入的字是正确的。


设置

单击查看 > 设置，可为 Altiris ImageExplorer 设置首选项。 将显示"设置"对话框，可在其中设置选项，用于确认在用户界面中使用消息框执行的特定操作；设置用于显示内容项或排除内容项的选项；或选择使用快速打印（请参阅打印文件）或快速打开（请参阅打开文件）选项时的默认程序。

确认

只读打开操作: 当以只读状态打开一个文件时，和任何更改都不能被保存时，向用户展示一个确认的消息。 例如： 例如：如果打开使用 RapiDeploy 4.5（或更早版本）创建的映像文件，则该映像将以只读状态打开，所执行的任何操作都无法保存。 因此，打开该文件时，将会显示确认消息框，提醒用户该文件无法保存。

文件改写操作: 当从一个映像文件提取一个文件时和在目标驱动器上改写一个现存的文件时，向用户展示一个确认的消息。

文件还原操作: 当执行一个还原操作，在替换文件之后返回映像文件到它的原来文件结构和内容时向用户展示一个确认的消息。

粘帖和拖放操作: 当在一个映像文件中拖放一个文件到一个新的文件夹时，和使用复制和粘帖操作来搬移文件到另一个文件夹时，或当使用添加新文件命令时想用户展示一个确认的消息。

排除操作: 当分派一个 "排除" 选项到一个文件 (不是分派结果文件作为映像的一部分) 时向用户展示一个确认的消息。 单击文件或文件夹上的复选框或选择 "排除" 操作时将显示此消息。

文件夹改写操作: 当从一个映像文件解压缩一个文件夹时和向一个目标驱动器上的现存文件夹改写时向用户展示一个确认的消息。

显示设置

保持帮助在顶部: 选择将帮助文件打开在 ImageExplorer 用户界面的顶部。 此项允许您同时查看帮助和程序，而不是将帮助隐藏在 ImageExplorer 用户界面的背后。

显示文件数目:显示在映像文件中的关联的文件数目。 NTFS 文件系统自动对文件进行编号。 在 FAT、EXT2、EXT3 和其他文件系统中，RapiDeploy 会在创建映像文件时对文件进行编号。

显示排除的文件: 显示在映像文件中标记为 "排除" 的文件。 刷新屏幕后将显示这些文件。

提取排除的项目: 允许将排除文件和文件夹从映像文件提取到一个目标文件夹。 此设置允许您在运行 "提取" 命令时包含所有先前被标记为 "已排除" 的文件以便将其保存到外部目标文件夹。

为添加项目着色: 选择此选项将添加到映像文件的文件/文件夹标记为蓝色文本。 请参阅添加文件和添加文件夹。

为替换项目着色: 选择此选项将替换到映像文件的文件/文件夹标记为青色文本。 请参阅 替换文件 （仅用于文件）。

为排除项目着色: 选择此选项将添加到映像文件的文件/文件夹标记为红色文本。 请参阅 排除。

打开和打印文件的默认程序

这些设置是使用打开方式和打开功能时出现的"快速打开"和"快速打印"选项的默认设置。 用于将文件与常用程序（如 Microsoft 记事本）相关联。

用以打开的程序: 设置与选择的文件一起运行的默认程序。 默认的程序是 Microsoft 记事本。 请参阅 打开文件。

用以打印的程序:设置用来打印选择的文件的默认程序。 默认的程序是 Microsoft 记事本。 请参阅 查找文件。


拆分映像

此功能允许您根据选择的区段大小，将所选映像文件拆分为（重新写入）新的文件。 使用转换映像可以将映像的文件格式更改为 RapiDeploy 使用的当前格式，拆分映像则会保留原始映像的格式，但会改变区段的大小。

例如： 例如：如果有一个 2 GB 的映像文件，您希望拆分该映像，以便能够存放在 CD 上，则可以选择 650 MB 或 700 MB 作为新区段大小，拆分后的映像文件包含多个区段。 然后将这些区段复制到 CD 上，并使用这些区段在客户机上还原映像文件。

拆分映像文件时，应注意以下几点：

  • 如果旧映像是旧格式的映像（IBMaster 4.5 或更早版本），则不会拆分该映像，而是对其进行转换。 如果出现这种情况，则会显示一则消息，要求确认您是否希望转换。如果继续，则将应用转换和映像处理。
  • 如果旧映像具有映像索引 (.imx) 文件，则会创建新的映像索引文件。
  • 如果旧映像文件是自解压映像，则会保留内嵌的 RapiDeploy 代码，新映像将包含最初创建映像时的 RapiDeploy 版本。 但是，如果该映像是旧文件格式（IBMaster 4.5 或更早版本），则不会拆分该映像，而是对其进行转换。 如果继续，则会删除自解压代码。
  • 如果旧映像带有密码，则新映像文件会包含相同的密码。 但是，如果旧映像是旧文件格式（IBMaster 4.5 或更早版本），则不会拆分该映像，而是对其进行转换。 如果继续，则会删除密码。
字段定义

要拆分的映像文件: 选择要拆分的映像文件。

当前区段大小: 按默认，RapiDeploy 映像的区段大小是 2 GB。

当前区段计数: 在映像文件中的区段数。

新输出映像文件: 选择要拆分的映像文件的文件夹和文件名。

新区段大小 (MB): 从下拉列表中为映像区段选择一个大小。 此选项列表包括 CD、zip 驱动器等介质的默认大小。 当文件区段达到此限制时，就会创建新的区段，直至整个映像均拆分完毕。

估计的区段计数: 根据新的区段大小决定要拆分的文件中的区段的估计数目。

拆分映像文件
  1. 单击文件并选择拆分映像文件。
  2. 单击浏览以定位文件夹，选择要拆分的映像文件。
  3. 单击浏览以定位文件夹，为映像输入新的文件名。
  4. 单击下拉列表箭头，从列表中选择区段大小。
  5. 单击确定。


命令行开关（参数）

此功能可用于创建 Deployment Server 运行脚本或批处理作业，帮助您通过命令行管理映像。 在某些开关（参数）的末尾，会列出选择选项，这些选项为可附加的命令。

访问联机命令行选项
  1. 在 Windows 环境中，单击开始> 运行。
  2. 在打开字段中输入 CMD 命令。
  3. 输入 C:\Program Files\Altiris\eXpress\Deployment Server\（默认安装路径）。
  4. 输入 imgexpl /? 以显示命令行开关页。
    命令行
    说明
    参数
    要打开或操作的映像文件（可以重复，例如 w2k.img、xp.img）。
    开关
    注册: 在 Windows Registry 中的注册表文件类型。
    取消注册: 在 Windows Registry 中取消注册。
    添加 <来源> <目标>: 添加文件，文件夹或卷到一个映像。 允许使用
    <-overwrite> 选项。 在输入来源 (src) 时可以使用通配符。
    提取 <来源> <目标>: 从一个映像提取一个文件，文件夹或卷。 允许使用 <改写> 和 <大小> 选项。
    转换 <目标>: 转换一个旧格式映像到一个被 RapiDeploy 使用的当前映像格式。 允许使用 <改写> 和 <大小> 选项。
    拆分 <目标>: 拆分一个又一个映像到新大小的文件区段。 允许使用 <改写> 和 <大小> 选项。
    选项
    语言 <语言代码>: 为用户界面指定语言代码。
    沉默: *不显示确认或错误。
    密码 <密码>: *映像文件的密码被打开。
    改写: 在沉默模式时，不要确认操作。
    大小 <以 MB 为大小>: 以 MB 为大小的新映像区段。
    * 表示该选项可用于任何命令。
    处理退出代码
    0 成功。
    2 命令行语法错误。
    4 注册或注销文件类型时出错。
    6 操作已被用户取消。
    8 试图向只读映像文件写入数据。
    10 密码无效。
    12 执行某个操作时出错。
    14 未找到映像文件，或打开映像时出错。.
    16 未找到来源，或打开来源时出错。
    18 未找到目标，或打开目标时出错。

例如:

  1. 打开需要密码 "develop" 的映像 W2k.img。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop
  2. 打开两个密码不同的映像文件，密码分别是 "password" 和 "sales"。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop f:\w2k.img -password sales
  3. 将 e:\ 下的所有 .txt 文件 (*.txt) 添加到该卷（位于 w2k.img 的第 1 插槽）的 temp 文件夹中。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop -add e:\*.txt 1:\temp
  4. 从 w2k.img 的 sys 卷的 Windows 文件夹中将 kernal.dll 提取到 e:\dump 中。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -password develop -add e:\*.txt 1:\temp
  5. 将旧格式的映像文件 w2k.img 转换成新映像 new2k.img，区段大小为 650 MB。
    • C:\Program Files\Altiris\eXpress\Deployment Server\imgexpl f:\w2k.img -convert f:\new2k.img -size 650